3

I've looked through almost all of the suggested questions as well as searched on the error messages in the attached logs and can't find anything applicable - at least as far as I understand things.

I'm running 14.04 LTS upgraded from 12.04 LTS. I recently installed ubuntu Tweak (at the same time I had to reinstall Software Center because it suddenly appeared as "not installed) and did a housecleaning. I also did an update that required a restart and now am unable to reach the login screen.

I've tried everything in recovery mode. I am unable to start in the failsafex (graphics safe mode), receiving a message as follows:

X: cannot stat /etc/X11/X (No such file or directory), aborting

I've tried hitting Esc to disable the splash screen and things appear to be going fine until something reads "FAIL", but the screen flashes by so fast I don't know what it is and don't know how to slow it down or interrupt it. Several more processes load and then it stops and the screen then only shows:

 Initct1: Event failed

and freezes there.

I'm running an ASUS laptop with an AMD64 chipset with 4GB of RAM and a 1 GB HDD dual booted with Windows 7 (into which I can boot, but very seldom use because of update problems I haven't been able to solve).

I wanted to attach the following files: /var/log/boot.log and /var/log/dmesg but I don't have "Manage Attachments" button to do so. So, I'll just add the last several lines of each file.

/var/log/boot.log

 * Starting CPU interrupts balancing daemon[154G[ OK ]
 * Starting configure virtual network devices[154G[ OK ]
 * Starting cups-browsed - Bonjour remote printer browsing daemon[154G[ OK ]
 * Stopping Restore Sound Card State[154G[ OK ]
 * Starting crash report submission daemon[154G[ OK ]
 * Starting automatic crash report generation[154G[ OK ]
 * Starting SMB/CIFS File and Active Directory Server[154G[[31mfail[39;49m]

/var/log/dmesg

[   21.351655] USB Video Class driver (1.1.1)
[   21.781351] init: failsafe main process (664) killed by TERM signal
[   21.914152] cfg80211: World regulatory domain updated:
[   21.914158] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[   21.914160] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[   21.914162] cfg80211:   (2457000 KHz - 2482000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[   21.914165] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[   21.914167] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[   21.914169] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[   23.325998] init: Failed to spawn hybrid-gfx main process: unable to execute: No such file or directory
  • issue an "ls /etc/X11" whats the output? – Spilt_Blood Feb 23 '15 at 21:35
  • fyi, I'm running Xubuntu from a flash drive on the same computer. But I stopped and booted from the hard drive into recovery, root prompt and then ran the command from there as you wrote it and the output was "No such file or directory." I then rebooted into Xubuntu, opened a terminal and ran it with the path to the partition on the hard drive and the output was: – Lisa Branechild Feb 23 '15 at 22:18
  • "app-defaults rgb.txt Xreset Xsession.d cursors xinit Xreset.d Xsession.options default-display-manager xkb Xresources xsm fonts xorg.conf.failsafe Xsession Xwrapper.config " – Lisa Branechild Feb 23 '15 at 22:19
  • fyi, the actual command I issued in Xubuntu was "ls /media/xubuntu/b339d35a-f956-4cad-a0d5-d192024dccd//etc/X11". Note the double forward slash. Don't know what that did to get results when the other got nothing. – Lisa Branechild Feb 23 '15 at 22:32
  • Only thing I can think of is permissions. Check who the owner is (ls -al /etc/ | grep -a -e X11). If the third and fourth rows aren't root try chown'ing "/etc/X11" as root:root (chown -R root:root /etc/X11). It seems as though the files exist, but 14.04 refuses to see them. I've never seen this before. I would make a backup in Xubuntu first before proceeding! – Spilt_Blood Feb 23 '15 at 22:50
0

Issue an ls /etc/X11 whats the output? Check who the owner is ls -al /etc/ | grep -a -e X11. If the third and fourth rows aren't root try chown'ing "/etc/X11" as root:root (Backup first)chown -R root:root /etc/X11.

Look in /usr/bin for Xorg. if it exists link to it and call your link X (make sure you put the link in /etc/X11). Then issue a startx and see what happens.

If Xorg is missing try reinstalling X via apt-get remove --purge xserver-xorg&&apt-get install xserver-xorg, or you can try to reconfigure with dpkg-reconfigure xserver-xorg

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.