3

We have been making custom made initrd.gz generated through debian-installer for 10.04 and 12.04 ubuntu.

We have been partitioning the disk and have made it automated completely and ask user to answer only few questions.

The problem I am facing is as below:

==========================================

You have mounted partition on /dev/sda

Would you like the installer to unmount it

===========================================

In 14.04.1 ISO /dev/sda1 is mounted on to /media and doesn't get unmounted even if I use preseed/early_command string umount /media I have tried all options of umount –l –f

Due to this a user has one more question to answer.

Neither does partman/unmount_active boolean true work

Earlier in 12.04, It would not ask to unmount the disk as /dev/sda1 was never mounted to media.

Is there a solution to either unmount the disk or set the Boolean as true through preseed?

0

This seems to be bug 1347726 which has not yet been resolved.

So I guess the answer, as of mid 2016, is: No.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.