0

I tried installing ath9k from backports looking here for tp-rink wn722nc.

After doing everything I rebooted my computer, but now I don't have wlan0. my internel wifi card is bcm43142 802.11 b/g/n. It's like here.

I had wifi connection before installing ath9k.

modprobe wl:

   modprobe: ERROR: could not insert 'wl': Invalid argument)

lshw -c net :

  *-network               

       description: Ethernet interface

       product: RTL8101E/RTL8102E PCI Express Fast Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:01:00.0
       logical name: eth0
       version: 08
       serial: 50:af:73:6b:33:f4
       size: 100Mbit/s
       capacity: 100Mbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full firmware=rtl8106e-2_0.0.1 04/23/13 ip=192.168.0.7 latency=0 link=yes multicast=yes port=MII speed=100Mbit/s
       resources: irq:105 ioport:1000(size=256) memory:d0504000-d0504fff memory:d0500000-d0503fff


 *-network UNCLAIMED


       description: Network controller
       product: BCM43142 802.11b/g/n
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:02:00.0
       version: 01
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress cap_list
       configuration: latency=0
       resources: memory:d0400000-d0407fff

lsmod has ath9k at its result, but no wl.

My questions are

  1. Can network manager support 2 wireless drivers?

  2. if not, how do I switch between drivers?

  3. where is my wlan0?

Please help me find wlan0.

  • Add the result of lshw -c net to your question – Jeremy31 Feb 23 '15 at 16:45
  • 1
    Don't do that with Broadcomm drivers! Go here instead: installing broadcom Wireless drivers and report back. – Fabby Feb 23 '15 at 16:48
  • ath9k is a driver for an Atheros wireless card, not Broadcom. – chili555 Feb 23 '15 at 16:55
0
cd backports-3.16-1
sudo make uninstall

Reboot and if it still doesn't work do:

sudo apt-get update && sudo update-pciids
sudo apt-get install --reinstall bcmwl-kernel-source
  • Thanks, jeremy31 and kasiya. My wlan is working now. Thanks again! – Seyoung Feb 24 '15 at 7:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.