6

TL;DR: I'm experiencing the small resolution issue in Ubuntu 14.04.2 on VirtualBox, and when I try to follow the answers to existing questions, either it doesn't solve the problem or I encounter certain obstacles that block me from completing the instructions (details below).

Background

The underlying problem is after installing Ubuntu 14.04.2 Desktop (32-bit) as guest VM in VirtualBox on a Windows 7 host, I'm having the small screen issue.

What I've tried already

I've already searched existing questions on this site regarding "small resolution in VirtualBox," but none of the answers to existing questions have solved my problem in 14.04.2, which leads me to believe that this may not be a duplicate. Here are the questions to which the answers I've tried, with no luck.

  1. Screen Resolution Problem with Ubuntu 14.04 and VirtualBox
  2. cannot change screen size from 640x480 after 14.04 installation on VirtualBox OSX

Specifics

Failed Resolution Path #1:

The top answer for the first question says:

You basically need the Guest additions, log into the Virtual Machine to install the following packages:

sudo apt-get install virtualbox-guest-dkms \
virtualbox-guest-utils virtualbox-guest-x11

Finally restart the VM to complete the installation.

My first attempt failed, apparently because of unmet package dependencies for virtualbox-guest-x11. Here's the link to the output on paste bin: http://pastebin.com/n0v1SLcW.

Based on the message, I tried installing the xorg-video-abi-15 package and got a similar message about unmet dependencies - link to output on paste bin: http://pastebin.com/pxk2XpK5.

After that, I gave up because there must be a better way than traversing the entire tree of unmet dependencies, am I right?

Failed Resolution Path #2:

The second-highest answer says to go to System settings → Software and Updates → Additional drivers within the guest OS, choose "Use x86 virtualization solutions...", reboot VirtualBox, and after that it solved the problem for that particular user, but I tried these steps, and I still have the small resolution issue.

Failed Resolution Paths #3 and #4:

The second question listed above says to just do sudo apt-get install virtualbox-guest-dkms (and restart the guest) to resolve the problem, but this doesn't work for me, either. The second highest answer to the second question listed above says updating VirtualBox to the latest version, which at the time was 4.3.10 r93012, resolved the problem for that particular user, but I have an even later version (4.3.12 r93733), and when I do Help > Check for Updates, the updater pop-up says "The network operation failed with the following error: Unknown reason."

Failed Resolution Path #5:

In addition to the answers provided in the questions listed above, I've tried installing guest additions from the Devices menu in VirtualBox. The steps that I tried for this are log into the guest OS as super user, in the VirtualBox window go to Devices > Insert Guess Additions CD, click Run in the resulting pop-up, and authenticate as super user. After authenticating as super user, a terminal window opens up and does some things. After the processing is complete, this is what it says in Terminal: http://pastebin.com/72WH6aY4.

Per the instructions in the Terminal output, I looked at /var/log/vboxadd-install.log to find out what went wrong, but that is a long, scary file with lots of information that I'm not sure what to do with (if anyone has any guidance on what specifically to look for in that file, I'd greatly appreciate it).

Summary

In summary, I've tried five different possible resolution paths, including all the recommended answers to questions that I could find by searching this site, and none of them have solved this problem for me in 14.04.2. Because of this, I suspect that there must be some different process for resolving this issue on Ubuntu 14.04.2. By the way, I was able to resolve the small screen issue on a 14.04.1 guest by simply installing the virtualbox-guest-dkms package, but for 14.04.2 I've hit a brick wall. Any help would be appreciated.

  • 1
    You may wish to consider using 14.04.1 instead of 14.04.2 which has numerous issues. The image can be dl'ed for 32bit - releases.ubuntu.com/14.04.1/ubuntu-14.04.1-desktop-i386.iso or you can look thru here, looking for 14.04.1 images releases.ubuntu.com/14.04.1 – doug Feb 23 '15 at 18:39
  • @doug: Thanks for your suggestion. I failed to mention explicitly in my original question, but I'm going to use 14.04.1 in the near term until I can resolve the screen size issue that affects 14.04.2. I also recognize that the answer (for now) might possibly be, 14.04.2 just came out less than a week ago and this is a prime example of why not to adopt a new version too soon. Also, per the potential answer provided by Takkat, when I get home I'll try updating my VirtualBox to the latest version (in some other way besides using the Help menu, which has failed me multiple times already). – Scott Feb 23 '15 at 20:25

11 Answers 11

7

I was having similar problems with virtualbox-guest-utils virtualbox-guest-x11 error messages. Then found this. I did the three steps, restarted and the screen is perfect.

I did: sudo apt-get remove libcheese-gtk23

Then: sudo apt-get install xserver-xorg-core

And finally: sudo apt-get install -f virtualbox-guest-x11.

It solved the problems for me.

  • Works for me! I don't know why exactly, but it works! – Aaron Schumacher Jun 13 '15 at 22:45
  • 14.04.5: You only need: sudo apt-get install xserver-xorg-core and sudo apt-get install virtualbox-guest-x11 REBOOT. That's enough. With that said, the best option is to simply use newest ISO .. as mentioned in other answer. – bshea Aug 25 '16 at 3:33
6

When installing Ubuntu 14.04.2 from disc we will also install the HWE stack by default (this is not the case on upgrading a pre-existent 14.04 installation). By this a newer version (1.16) of the xorg-server will be provided.

Virtual Box supports this Xorg-Server only from version 4.3.16 and later. Earlier versions do not support the newer Xorg server. Apparently you had version 4.3.12 installed.

Therefore rather than downgrading your Ubuntu installation it is recommended to upgrade Virtual Box on your host to a newer release (at present 4.3.22).

  • Thanks for your suggestion. I updated to the latest version of VirtualBox (4.3.22 r98236) and did a fresh install to a new guest VM using the Ubuntu Desktop 14.04.2 32-bit image and unfortunately I still encounter the same obstacle when trying to install virtualbox-guest-x11 (or xorg-video-abi-15 or xserver-xorg-core individually). – Scott Feb 24 '15 at 2:32
  • @Scott: in your guest you should not install Virtual Box components provided from the Ubuntu repositories (they still are from version 4.3.10) but install the guest additions provided with your Virtual Box install. Hope it then will work (can't test this as I have no access to a HWE enabled 14.04.2). If not I then consider this a bug of either the 14.04.2 packages, or of virtualbox which should be reported appropriately. – Takkat Feb 24 '15 at 7:32
  • And it looks like currently 4.3.12 is the most recent version which is working on Windows due to this issue. – vorou Mar 8 '15 at 10:01
4

Solution that worked for me: Go on this link http://download.virtualbox.org/virtualbox/ Find the exact version of your Virtualbox and download the VBoxGuestAdditions_version.iso Then plug it into the VM and allow it to run (it was automatic for me).

Hope this helps.

  • After trying many other solutions which didn't work for me (mostly led me down a rabbit-hole of other problems) this one worked for me - with one minor addition - I had to restart the VM after installing. – Mark Smith Apr 21 '15 at 14:10
2

Just do this:
1) open your terminal in ubuntu guest os

2) type: sudo apt-get remove libcheese-gtk23

3) then: sudo apt-get install xserver-xorg-core

4) then: sudo apt-get install -f virtualbox-guest-x11

5) after typing the 3rd command type y or i when asked and wait for it to finish

6) Restart now and your problem should be solved.

0

@Takkat is spot-on. The problem is the version of X Server on the GUEST in relation to what the HOST's version of Virtualbox will support in order to get full-screen.

You can get the version of X Server with X -version. Run this on the GUEST to see which version is installed. Of note, there is one - rather than two --. Also, this command outputs to stderr rather than stdout. This strikes me as odd, but perhaps someone can fill in the blanks as to why.

Putting it all together, X -version |& grep 'X Server' will get you something like "X.Org X Server 1.15.1". Note that |& is necessary to pipe both stdout and stderr.

You can do another grep on that to isolate the version number if you are scripting something for validation.

This was sufficient for me to hardcode the supported version of X Server on the guest that my virtual machine setup script will work on. I assume that the host will run "default" Ubuntu with the older version of Virtualbox, so I just tell users to run 14.04.1 as the guest.

0

Windows 7, VBox 4.3.12 r93733 (current version does not play nice with Avast)

I spent hours trying to get this working full screen, these 3 steps worked, thank you!

System settings menu item not working, so I had to sudo apt-get install unity-control-center all working now.

0

I ran into the same problem, and these steps fixed it:

1) On the host, use the latest version of VirtualBox from virtualbox.org. (I used 4.3.26).

2) On the guest (Ubuntu 14.04.2), run

sudo apt-get install linux-headers-generic

3) On the guest, do not use the Ubuntu repositories to install the guest additions.

Instead, press Host+D to use the guest additions ISO bundled with the newer version of VirtualBox that you downloaded to the host.

You shouldn't see any X11 package issues when installing the guest additions ISO.

Reboot and the screen size should be fixed.

0

Experience has been same for me on windows7 host and ubuntu 12.04. The solution that seems working for me is disabling the max resolution limitation in vbox, by typing

VBoxManage setextradata global GUI/MaxGuestResolution any

The source is from a ticket at the virtualbox website.

0

This problem is on Virtualbox 5.0.4 The command did not solve my problem Open a New terminal > Install from the menu Devices > "*..Guest Additions" and then accept the installation in ubuntu, reboot and ready

0

I run:

sudo apt-get remove libcheese-gtk23

then:

sudo apt-get install xserver-xorg-core

and finally:

sudo apt-get install -f virtualbox-guest-x11

It solved problems for me.– conradk

I found this in the website,it did work for me

0

Just installed 14.04.5 and had same issues. Resolved by installing virtualbox-guest-x11-wily. Looks like this version of ubuntu has xorg stack from backported from wily (15.10) and corresponding guest driver installed fine and gave normal resolution.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.