I use the Compiz Widget Layer plugin so as to have a fullscreen Terminator window a keystroke away. The only issue I have is, when I'm in the Widget Layer, notifications don't appear, so I don't come to know when someone sends me an IM in Pidgin. Does anyone have a solution that can make libnotify notifications appear in the Widget Layer?

  • Have you managed to solve this problem or are you still looking for help? If this question no longer applies then you can either delete it or answer it yourself if you've solved the problem. Thanks! – coversnail Apr 16 '12 at 13:09
  • 1
    Thanks for the reminder, I'd forgotten about this :). I've answered the question below. – Vicky Chijwani Apr 16 '12 at 19:29

I found that libnotify is designed in such a way as to not disturb users when they're using a fullscreen application, and that does make sense from a design point of view. So instead of using Terminator fullscreen, I got rid of its titlebar using the "Window Rules" plugin. This way it looks like it's fullscreen, and I also receive notifications properly.

|improve this answer|||||

I have a possible solution, but I have not tested it so you will have to comment and tell me if it works.

Add (title=notify-osd) to your Widget Layer match option as follows: enter image description here

In light of your comment (that this does not seem to work), I suggest reporting a bug against compiz. (ubuntu-bug compiz).

|improve this answer|||||
  • It doesn't work. I have a new theory: I think the problem is that I've set the Terminator window to fullscreen using Window Rules, and that is what's causing notifications to not appear, not the Widget Layer. If that's true, is there a solution to it? What do you think? – Vicky Chijwani Aug 29 '11 at 6:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.