0

I have looked everywhere but i can't seem to find an answer

I Have a laptop (Acer V3-5726-54S6) 1tb 8gbRam with an integrated intel gpu and a Nvidia GT840m(2gb). Running Ubuntu 14.04 with cinnamon and mdm

i'm trying to get the nvidia card to work with cinnamon using mdm but i can't seem to get it to work. i've tried

  • bumblebee. editing bumblebee.conf. editing xorg.conf.nvidia
  • bumblebee with nvidia-340 driver,
  • bumblebee with nvidia-331
  • bumblebee with nvidia-337
  • bumblebee with nvidia-current -- nvidia drivers (from website and xorg-edgers ppa)
  • nouveau drivers

when i used bumblebee i tried

    $ optirun (any program)

and i got back

[ERROR]Cannot access secondary GPU - error: Could not load GPU driver

[ERROR]Aborting because fallback start is disabled.

this happened on all the different drivers i used (331,337,340,current) so i uninstalled bumblebee* and nvidia* tried installing nvidia drivers from the website but that crashes cinnamon.

tried installing the driers without bumblebee (331,340)

selected lightdm when it gave me the option, rebooted, and i got a black screen after boot splash screen. when i chose mdm, cinnamon crashed...

also

$ lspci | egrep 'VGA|3D'

and got back

00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 0b)

03:00.0 3D controller: NVIDIA Corporation GM108M [GeForce 840M] (rev a2)

any help?

1
  • also i tried enabling fallback in bumblebee but that just switched to the intel card
    – Aj Dich
    Feb 23, 2015 at 10:31

1 Answer 1

0

First of all, I am not sure if I will help you with this, but I am currently unable to comment on your question.

I am assuming that you have followed this sequence:

sudo apt-get install linux-headers-generic
sudo apt-get install bumblebee primus primus-libs-ia32

than nvidia driver:

sudo add-apt-repository ppa:xorg-edgers/ppa 
sudo apt-get update
sudo apt-get install nvidia-xxx

or

sudo apt-get install bumblebee-nvidia

in the end, reinstall bbswitch-dkms:

sudo apt-get install --reinstall bbswitch-dkms

Edit configuration files, reboot.

If not:

sudo apt-get remove --purge nvidia-xxx
sudo apt-get remove --purge bumblebee

If you have bumblebee-nvidia, replace it in code. Now reinstall everything starting from the top.

I can report that nvidia-346 won't work, you will just get a black screen after reboot, and will have to purge nvidia and x-server and reinstall x-server to get system back to normal.

I think that there is no way of safely installing nvidia driver conventionally (from nvidia-XXX.run) on Optimus systems, I have tried that few times and failed.

How exactly did you edit bumblebee, bumblebee.conf, xorg.conf.nvidia?

I've been getting that error when I happened not to have right driver name specified in bumblebee.conf.

I will give you my bumblebee.conf under the text. Have in mind that I am using default driver (bumblebee-nvidia). We are using the same OS.

However, I think the problem will latter arise in BusID line in xorg.conf.nvidia. As you can see, BusID of your nvidia card is 03:00.0, and yet, default BusID in nvidia.conf file is 01:00:0. Currently, line is like this:

#   BusID "PCI:01:00:0"

You need to remove hashtag and change the value, so that it would be like this:

    BusID "PCI:03:00:0"

Try out my bumblebee.conf, edit BusID in xorg.nvidia.conf, and see what happens. I hope this will be of any help.

Waiting for respond.

# Configuration file for Bumblebee. Values should **not** be put between quotes

## Server options. Any change made in this section will need a server restart
# to take effect.
[bumblebeed]
# The secondary Xorg server DISPLAY number
VirtualDisplay=:8
# Should the unused Xorg server be kept running? Set this to true if waiting
# for X to be ready is too long and don't need power management at all.
KeepUnusedXServer=false
# The name of the Bumbleblee server group name (GID name)
ServerGroup=bumblebee
# Card power state at exit. Set to false if the card shoud be ON when Bumblebee
# server exits.
TurnCardOffAtExit=false
# The default behavior of '-f' option on optirun. If set to "true", '-f' will
# be ignored.
NoEcoModeOverride=false
# The Driver used by Bumblebee server. If this value is not set (or empty),
# auto-detection is performed. The available drivers are nvidia and nouveau
# (See also the driver-specific sections below)
Driver=nvidia
# Directory with a dummy config file to pass as a -configdir to secondary X
XorgConfDir=/etc/bumblebee/xorg.conf.d

## Client options. Will take effect on the next optirun executed.
[optirun]
# Acceleration/ rendering bridge, possible values are auto, virtualgl and
# primus.
Bridge=virtualgl
# The method used for VirtualGL to transport frames between X servers.
# Possible values are proxy, jpeg, rgb, xv and yuv.
VGLTransport=proxy
# List of paths which are searched for the primus libGL.so.1 when using
# the primus bridge
PrimusLibraryPath=/usr/lib/x86_64-linux-gnu/primus:/usr/lib/i386-linux-gnu/primus
# Should the program run under optirun even if Bumblebee server or nvidia card
# is not available?
AllowFallbackToIGC=false


# Driver-specific settings are grouped under [driver-NAME]. The sections are
# parsed if the Driver setting in [bumblebeed] is set to NAME (or if auto-
# detection resolves to NAME).
# PMMethod: method to use for saving power by disabling the nvidia card, valid
# values are: auto - automatically detect which PM method to use
#         bbswitch - new in BB 3, recommended if available
#       switcheroo - vga_switcheroo method, use at your own risk
#             none - disable PM completely
# https://github.com/Bumblebee-Project/Bumblebee/wiki/Comparison-of-PM-methods

## Section with nvidia driver specific options, only parsed if Driver=nvidia
[driver-nvidia]
# Module name to load, defaults to Driver if empty or unset
KernelDriver=nvidia-current
PMMethod=bbswitch
# colon-separated path to the nvidia libraries
LibraryPath=/usr/lib/nvidia-current:/usr/lib32/nvidia-current
# comma-separated path of the directory containing nvidia_drv.so and the
# default Xorg modules path
XorgModulePath=/usr/lib/nvidia-current/xorg,/usr/lib/xorg/modules
XorgConfFile=/etc/bumblebee/xorg.conf.nvidia

## Section with nouveau driver specific options, only parsed if Driver=nouveau
[driver-nouveau]
KernelDriver=nouveau
PMMethod=bbswitch
XorgConfFile=/etc/bumblebee/xorg.conf.nouveau
2
  • I am using virtualgl as a bridge, as you can see. If you want primus instead, change Bridge=virtualgl into Bridge=primus.
    – gogeccc
    Feb 25, 2015 at 17:35
  • didn't help, but thanks... i installed windows in a separate partition so it's all good
    – Aj Dich
    Feb 26, 2015 at 20:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .