2

On Ubuntu 15.04 Unity, how can I enable the global menu bar for the Qt application RStudio?

I found a 12.04 question, which was not solved and did not contain a clue.

(Due to reputation issues, I could not add the RStudio tag).

1
  • Both solutions don't seem to work under Ubuntu 16.04 and the recent RStudio Version 0.99.903 any longer. :( Is there a new solution for the actual Version? – YetanotherQuestion Oct 31 '16 at 13:05
2

edit:

It is reported (see comments), that Ubuntu 16.04 and/or RStudio release 0.99.467 (using Qt5) or later do not support the following solution any more. See also the answer of lyz1990.


I found a solution on the RStudio forum (here). The issue has reported several times (e.g. here and here).

To enable the appmenu-qt for RStudio, link the qt4 menubar to the rstudio library folder. Run the following commands in a terminal:

cd /usr/lib/rstudio/bin/plugins
sudo ln -s /usr/lib/x86_64-linux-gnu/qt4/plugins/menubar

Then (close and) start rstudio. This is how it looks like:

Enable global application menu with RStudio

5
  • Your command seems incomplete (the ln command usually takes two arguments). Typo? – muru Feb 23 '15 at 10:55
  • 2
    Read man ln and see the 2nd form. The link name is optional. It is taken from the target name. – setempler Feb 23 '15 at 12:37
  • 1
    Indeed. I'd still use third or first forms and skip the cd: sudo ln -s /usr/lib/x86_64-linux-gnu/qt4/plugins/menubar /usr/lib/rstudio/bin/plugins. – muru Feb 23 '15 at 12:39
  • Usually I do use it your way, but a line break does not look so nice in the code block... – setempler Feb 23 '15 at 12:40
  • 2
    No longer seems to work for version 0.99.467, which uses Qt5. – Ricardo Magalhães Cruz Aug 14 '15 at 17:37
1

For recent versions of Rstudio with Qt5:

cd /usr/lib/rstudio/bin/plugins/platformthemes
sudo ln -s /usr/lib/x86_64-linux-gnu/qt5/plugins/platformthemes/libappmenu-qt5.so libappmenu-qt5.so

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.