15

I want to record sound from mic in Ubuntu 14.04 LTS. I do this with good quality in windows 7 or 8.1. I am using the pulse input(pulse audio) with audacity. It records voices but with lots of noises. I use noise removal in effect tab but the outcome has very bad quality.

I tried audio recorder but it record voices with noise, too.

Can anyone help me?

My laptop is a Lenovo z410.

20

Type in the terminal alsamixer. It will open the present levels, adjust the microphone level at 75 and set the microphone boss level to 50. Worked for me perfectly and removed the noise from microphone.

| improve this answer | |
  • 9
    i don't understand your answer completely but it guide me to another way. after entering alsamixer, i press f4 to enter capture tab. then i set capture to 28 and internal mic boost to 51. the recording quality change a lot and it's now acceptable. – hussein ghasemi Mar 20 '15 at 15:04
  • I used mic boost 53 and capture 70 and it works great, no random noise! – formatc Oct 14 at 9:22
8

I tried this method it didn't work for me. I tried to active noise cancelation and it works perfectly. Here it is:

I found this solution Video , and it worked for me.

Open Terminal and run:

sudo nano /etc/pulse/default.pa

Add these lines at the end of the file:

### Enable Echo/Noise-Cancelation
load-module module-echo-cancel aec_method=webrtc aec_args="analog_gain_control=0 digital_gain_control=1" source_name=echoCancel_source sink_name=echoCancel_sink
set-default-source echoCancel_source
set-default-sink echoCancel_sink

exit from text editor with ctrl+x and save file.

run

 pulseaudio -k
 pulseaudio --start

restart the system.

Done!

From: https://askubuntu.com/a/1222714/864419

| improve this answer | |
  • In my case this improved the situation, but it makes the audio quality worse (digital distortion) & the hiss is still present, even if it's attenuated :/ Thanks anyway, I think that this is the right track to follow – funder7 Jun 1 at 12:27
2

I will provide a full answer based on answers given here and elsewhere.

So my recording was a total mess: sounds crackling, popping, with the sound of the processor, or the fan of the laptop.

What I did was to input the following commands:

1/ Restore alsactl

alsactl restore

It improved tremendously the quality but was still bad.

2/ Adjust microphone with Alsa mixer (Rajashekhar Ch's answer)

alsamixer

then

Fn + F4
Right arrow
Bring capture to !30 and microboost to ~50 
ESC

3/ Followed Mohammad's answer: edit /etc/pulse/default.pa by adding at the end:

### Enable Echo/Noise-Cancelation
load-module module-echo-cancel aec_method=webrtc aec_args="analog_gain_control=0 digital_gain_control=1" source_name=echoCancel_source sink_name=echoCancel_sink
set-default-source echoCancel_source
set-default-sink echoCancel_sink

Then

pulseaudio -k
pulseaudio --start

4/ Activate Noise cancellation in OBS:

enter image description here

You have to click on the settings button and then filters as seen on screenshot.

enter image description here

Play with the different ranges to see what works best for you.

| improve this answer | |
0

While recording, click at top right where you control sound. In the mic bar present there, just reduce the sensitivity of mic. This will remove the creepy sound of air and you can enjoy your sound

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.