2

I am running a Lenovo T440p with a clean install of Ubuntu. No dual booting. Over the weekend I upgraded from Ubuntu 14.04 to 14.10. There were some package install errors that led to Ubuntu being booted in 'low-graphics' mode. I ultimately fixed the package issues by deleting my installed cisco VPN client. I was then able to do an apt-get update and apt-get upgrade.

Here is where all that backstory leads: after rebooting my system, its like the bios doesnt even know there is an OS installed at all. It can see the HD, but it wont boot to it. And I am unable to open GRUB in any way.

I used the Live CD to install and run boot-repair with no luck. It says it completed successfully, but does not seem to have made a difference.

Ive tried just mounting the drive so I can get the files I need and reformat the thing. But I cant seem to get that to run either. It seems to map correctly, but when trying to mount using:

sudo mount /dev/mapper/encrypted /media/encrypted

I get the following error:

mount: wrong fs type, bad option, bad superblock on /dev/mapper/encrypted, missing codepage or helper program, or other error

Running dmesg | tail from there doesnt seem to provide any actionable help.

I am getting desperate here. And any help either mounting the drive, or better-yet repairing the boot process would be eternally appreciated.

  • I think a default full-disk encrypted Ubuntu can use a logical volume manager - LVM scheme, so you might have to open that before mounting. Why they do that, instead of just having one or more regular partitions that are encrypted & mounted, I'm not sure... unless they always want to have swap on it's own virtual partition. – Xen2050 Feb 25 '15 at 13:12
0

Basically there are two stages to this.

  1. decrypting
  2. mounting the Logical volumes

Assuming your drive is on sda5 (which is the Ubuntu default AFAIK but might be different)

sudo cryptsetup luksOpen /dev/sda5 luks

You are then promted for your password.

Than do the LVM stuff

sudo pvscan && sudo vgscan && sudo vgchange -a y

Use lsblk if you want to find out more information about the current layout of the connected drives after the vg are activated you can mount:

sudo mount /dev/ubuntu-vg/root /mnt 

Now you should be able to acces the drive content. Repairing is basically a seperate question I think this might be a relevant answer How to restore a system after accidentally removing all kernels?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.