I'm getting the following error message when attempting to install libglew-dev,

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libcheese-gtk23 : Depends: libclutter-gtk-1.0-0 (>= 0.91.8) but it is not going to be installed
                   Depends: libcogl15 (>= 1.15.8) but it is not going to be installed
 libcheese7 : Depends: libclutter-gst-2.0-0 (>= 0.10.0) but it is not going to be installed
              Depends: gstreamer1.0-clutter but it is not going to be installed
 libclutter-1.0-0 : Depends: libcogl-pango15 (>= 1.15.8) but it is not going to be installed
                    Depends: libcogl15 (>= 1.15.8) but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

All those packages are however apparently already installed.

I have tried all possible solutions in this post, without any luck. I have not added any PPAs. The version of ubuntu is 14.04.2.

I have looked at similar posts, and tried the following:


dpkg --get-selections | grep hold

prints nothing.

sudo apt-get -oDebug::pkgProblemResolver=true install -f

Gives me nothing of interest, 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

  • 1
    I faced the a similar problem with libcheese packages while trying to install libqtwetkit-dev. I solved using aptitude (after install it, you run similar as apt-get, but aptitude will give your alternatives to fix the problem. Mar 4, 2015 at 2:24

4 Answers 4


I tried to install libglew-dev and I had the same problem. I had to include the following packages to install it

sudo apt-get install  libglew-dev libcheese7 libcheese-gtk23 libclutter-gst-2.0-0 libcogl15 libclutter-gtk-1.0-0 libclutter-1.0-0  xserver-xorg-input-all

It will include then all the required packages.

  • tested on a clean 14.04.2 VM, your solution works flawlessly. +1 Mar 5, 2015 at 8:45
  • "All those packages are however apparently already installed." what are you doing differently?
    – Braiam
    Mar 6, 2015 at 4:29
  • 2
    The bug report on lp: #1428972 Mar 8, 2015 at 8:21
  • 1
    I tried that, but after restarting my touchpad stopped working.
    – Geoffrey
    Mar 11, 2015 at 1:05

I had the same problem in Ubuntu 14.04.2 trying to install qtcreator. Also trying to install Qt4/5 development packages such as qt4-default and qt5-default would have downgraded the whole X.org to the original trusty version instead of lts-utopic.

This dependency mess is somehow connected to the new Mesa packages, and can be fixed by manually installing lts-utopic versions. I installed these packages:

sudo apt-get install xserver-xorg-dev-lts-utopic mesa-common-dev-lts-utopic libgles2-mesa-dev-lts-utopic libgles1-mesa-dev-lts-utopic libgl1-mesa-dev-lts-utopic libegl1-mesa-dev-lts-utopic

Note: most issues with dev package install has been resolved with mesa 10.1.3-0ubuntu0.4

Packages are currently available in trusty -proposed

Referring bug - https://bugs.launchpad.net/ubuntu/+source/mesa/+bug/1424466


You can use Synaptic for installing libglew-dev package. There you can see all dependencies too and by marking needed dependencies for installing then click on Apply button would install your needed package.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .