2

I'd like to be able to have my KDE session started with lightdm auto login but lock immediately. But if I logout and then back in, I don't want the lock.

I found this bug:

https://bugs.kde.org/show_bug.cgi?id=300151

I'm currently using the solution in comment #4, (setting DESKTOP_LOCKED in .xprofile), but this always locks the screen, even if it wasn't an auto-login.

According to the links in comment #9 in the bug, autologin-in-background should do what I want. But it doesn't; using the following /etc/lightdm/lightdm.conf, the autologin proceeds on another screen, but it is not locked. All you have to do is switch to that screen (Ctrl-Alt-F8), no password required. Any idea what's wrong?

[SeatDefaults]
allow-guest=true
autologin-guest=false
autologin-session=lightdm-autologin
autologin-user=purtill
autologin-user-timeout=0
greeter-session=lightdm-kde-greeter
autologin-in-background=true

[VNCServer]
enabled=false

[XDMCPServer]
enabled=false
  • Forgot to say: I'm using Kubuntu 14.04. – Zeggpold Feb 22 '15 at 22:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.