I issued the command string found at https://wiki.ubuntu.com/Kernel/LTSEnablementStack and got this result:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 account-plugin-facebook : Depends: libaccount-plugin-generic-oauth but it is not going to be installed or
                                    ubuntu-system-settings-online-accounts but it is not going to be installed
 account-plugin-google : Depends: libaccount-plugin-google but it is not going to be installed or
                                  ubuntu-system-settings-online-accounts but it is not going to be installed
 libcheese-gtk23 : Depends: libcheese7 (>= 3.4.0) but it is not going to be installed
                   Depends: libclutter-1.0-0 (>= 1.13.2) but it is not going to be installed
                   Depends: libclutter-gtk-1.0-0 (>= 0.91.8) but it is not going to be installed
                   Depends: libcogl15 (>= 1.15.8) but it is not going to be installed
 libqt5gui5 : Depends: libgbm1 (>= 8.1~0) but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
  • Can you try running either sudo apt-get install libaccount-plugin-generic-oauth or sudo apt-get install ubuntu-system-settings-online-accounts? Feb 22 '15 at 16:15
  • you may have similar situation as here (the details of fail can vary), askubuntu.com/questions/588186/…
    – doug
    Feb 22 '15 at 16:40

If this issue comes up then you will have to uninstall those packages using either the Ubuntu Software center or apt-get.

To use the Ubuntu Software Center: Click on the icon on the Taskbar or use the Super key and type Ubuntu Software Navigate to the Installed packages and find the search bar and for each of those error giving packages type those in and uninstall them.

To use a Terminal(apt-get)

sudo apt-get autoremove packages | apt-get autoclean
sudo apt-get purge
sudo apt-get update

This ensure nothing is left behind.

Also wait for a Mesa update from the Software Center Updater. Then remove libqt5gui5

The packages needed to be removed are as follows


At this point use the command given from the wiki and install will occur.

Note: If there additional packages install involving this issue then use the apt-get command using the name of those packages specifically.


You can, probably, fix this issue by using "aptitude" " instead of "apt-get".

aptitude will gives you several solutions, and all you have to do is to choose the one that matches your needs.

I just had the "same" error when trying to install "qt4-dev-tools" through:

apt-get install qt4-dev-tools

and I solved the problem simply by replacing "apt-get" with "aptitude", then I have chosen one of the proposed solutions.

Best regards,

  • FINALLY got it to work when checking out the duplicate pointers above. Had to uninstall the Intel drivers and reinstall the correct drivers from the repositories. Also had to uninstall all of the packages mentioned above. After upgrading I found out that Skype and WINE were deleted by the HWE upgrade and both had to be reinstalled along with the packages I manually removed. What a PAIN!! But at least it all seems to be working now. Thanks, everyone!
    – Jaime Cruz
    Mar 22 '15 at 15:16
  • Oh boy! Just discovered the Unity Control Center (System Settings) was ALSO deleted by this. Beware!!
    – Jaime Cruz
    Mar 22 '15 at 15:35

You can fix dependencies issues by executing following commands.

sudo apt-get autoremove && sudo apt-get autoclean 
sudo apt-get update

Enable stacks by installing Kernel

sudo apt-get install --install-recommends linux-generic-lts-utopic xserver-xorg-lts-utopic libgl1-mesa-glx-lts-utopic libegl1-mesa-drivers-lts-utopic

Fix dependency issue.

sudo apt-get install -f 
  • Mesa comes up as an umet depenacy, this will require more than a simple soultion
    – Virusboy
    Feb 22 '15 at 17:23

You need to install xserver-xorg

sudo apt-get install xserver-xorg

Probably it will give error for gnome-control center.

You need to remove this using

sudo apt-get remove gnome-control-center   

Once this is over then re-try

sudo apt-get install xserver-xorg  

It will be now okay...

Not the answer you're looking for? Browse other questions tagged or ask your own question.