4

I've tried three other posts about how to install drivers for

  1. NVIDIA GeForce 6150SE nForce 430
  2. Video Drivers for Onboard GeForce 6150SE

  3. Nvidia geforce 6150-unity 3d won't work

The problem is I've tried installing all the drivers suggested, one by one, test them, remove them, install another and until now the one which is working best is nouveau, but It also freezes the screen on random actions, most notably when I start Firefox.

If you have this card installed and working well please tell us what driver/distribution/configuration you are using. Thank you.

Xorg.0.log file: http://pastebin.com/8HLG59y7

syslog tells me this:

Feb 23 11:55:19 xxxxxxx kernel: [ 48.418101] systemd-logind[1202]: Failed to start unit [email protected]: Unknown unit: [email protected]

Feb 23 13:22:30 xxxxxx kernel: [ 5286.305415] nouveau E[ PBUS][0000:00:0d.0] MMIO write of 0x00000000 FAULT at 0x00b010

4 Answers 4

3

I found that the correct driver (working well now for two days) is the nvidia-304 which can be installed from repositories. This might be problematic if you are making a clean install because the Geforce 6150SE will not work well when installing from the Ubuntu DVD: the Ubuntu live session will freeze, so follow this sequence:

  1. Boot from the DVD and press Space to choose different methods of installation.
  2. Choose Experienced Install.
  3. Install Ubuntu.
  4. After install is done, press CTRL+ALT+F1 and login.
  5. Update your system:

    sudo apt-get update

    sudo apt-get upgrade

  6. Install the driver:

    sudo apt-get install nvidia-304

  7. DO NOT run nvidia-xconfig (THIS IS IMPORTANT).

  8. Reboot the system (just press CTRL+ALT+DEL)
  9. Login normally.
  10. Open Nvidia X server settings from the dash.
  11. Backup your configuration (you can copy and paste it to a txt file)

I hope this helps others, it's worked for me (so far).

2
  • 1
    If you still have problems try sudo apt install nvidia-304=304.131-0ubuntu3 nvidia-opencl-icd-304=304.131-0ubuntu3
    – lapisdecor
    Feb 24, 2017 at 4:40
  • 1
    Using shutdown --reboot now might be preferrable to ctrl-alt-del, I'm not sure if all filesystems would get unmounted cleanly with ctrl-alt-del
    – Xen2050
    Aug 25, 2017 at 12:50
2

Correct can mean lots of things.

The nvidia drivers are proprietary and do not integrate well with the rest of the free software ecosystem and community. The nouveau driver is the preferred one, but in Debian testing and unstable it has a bug with the 6150SE, which you can workaround by inserting into /etc/modprobe.d/local-video.conf:

options nouveau noaccel=1

1
  • This fix doesn't work in Xubuntu 16.04 Sep 4, 2017 at 15:15
0

I have tried all the steps above with no results. I have tried everything. Finally Got it to work. Here's the problem with random screen freezes using any flavor of Linux with a older Nvidia graphics card, especially an integrated one like the Nvidia G force 430 series. Permanently add the Nomodeset.

As mention by user NikTh on Oct 27 '12 at 14:02, The newest kernels have moved the video mode setting into the kernel. So all the programming of the hardware specific clock rates and registers on the video card happen in the kernel rather than in the X driver when the X server starts..

This makes it possible to have high resolution nice looking splash (boot) screens and flicker free transitions from boot splash to login screen.

Unfortunately, on some cards this doesnt work properly and you end up with a black screen or in my case black screens and random freezes when watching a youtube video when using Firefox.

Adding the nomodeset parameter instructs the kernel to not load video drivers and use BIOS modes instead until X is loaded.

For help in adding these parameters, check out http://ubuntuforums.org/showthread.php?t=1613132

2
  • This also means you have no hardware acceleration.
    – oldtechaa
    Oct 25, 2016 at 20:36
  • This fix doesn't work in Xubuntu 16.04. The system lost the resolution. Sep 4, 2017 at 15:58
-2

I had the same experience with Linux Mint 19.0. The fix was to avoid the update to kernel 4.15 or to install Linux Mint 18.2 which works for me. I can do all of the updates and still have my video driver, Nvidia Geforce 1650 SE Nforce working.

I wanted to dual boot with either Debian or PCLinuxOS but since those are rolling releases, the updates break the system since the X driver gets moved into the kernel.

Another fix would be to just buy a cheap video card.

1
  • 1
    I'm not sure if same fix goes for Ubuntu.
    – Kulfy
    May 2, 2019 at 17:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .