I've just bought a new HP ProLiant MicroServer Gen8 a few days ago, and have been trying to install Ubuntu Server 14.04LTS on it since then, but I'm having an issue where it's not booting after install.

I'm attempting to install to a USB stick plugged into the internal USB port, from a stick with the standard 14.04LTS iso dd'd onto it. Installation starts and completes without incident, but after reboot I get dropped into a grub rescue shell.

During installation my source drive is at /dev/sda and my target is at /dev/sdb. I tried different disk set-ups:

  • Guided partitioning with LVM
  • Guided partitioning without LVM
  • A 24GiB ext4 marked bootable partition at '/' and a 8GiB swap (in that order)
  • A 1GiB ext4 marked bootable at '/boot/', 23GiB ext4 at '/' and a 8 GiB swap (in that order)

When it prompts me where to install grub, I tried both /dev/sdb (so it installs to MBR) and /dev/sdb1 (so it installs to the partition) for at least the last two options.

When I install grub to the disk, it simply doesn't boot (I've since read that installing grub to the partition is meant for when you're chain loading, so I guess that could be expected). If I install it to the MBR, I get dropped into a 'grub rescue' shell. From this shell, I can see the following (I'm writing this from memory from what I tried on the set-up with a single 24GiB system partition):

> ls
(hd0) (hd0,msdos1)

> ls (hd0)
(hd0): Filesystem is unknown

> ls (hd0,msdos1)
(hd0,msdos1): Filesystem is ext2

> ls (hd0,msdos1)/boot
error: attempt to read or write outside of disk 'hd0'

> ls /
[file list that looks like the root of a linux install]

> ls /boot
[file list that looks like the boot dir of a linux install, including grub folder, kernel and initial ramdisk]

> insmod normal
error: attempt to read or write outside of disk 'hd0'

> normal
'normal': command not found

> linux /boot/vmlinuz[kernel version goes here]
'linux': command not found

So this is where I'm stuck...

What am I doing wrong?


Just solved it by running the Ubuntu Desktop live iso from iLO virtual media (with a free iLO Essentails trail from HP) and running boot-repair.

Bit weird it didn't work out of the box, but hey, at least it's working now.

| improve this answer | |

My friend had the same issue when installing OpenMediaVault and Debian 7.0, it failed when trying to install GRUB on /dev/sda (1st SATA MBR).

I reckon this may be something to do with the debian installer. Asked him to upgrade BIOS, and try to chroot into the incomplete install and manually install GRUB again. Haven't heard back from him yet, will update with more details later.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.