Today i've installed Ubuntu 14.04.2 LTS on amd64 Lenovo G710 laptop. Unfortunately, this is not my PC and i have to fix this issue with not working Wifi. In network-manager tray tool i see "Qualcomm Network QCA8172 -- disconnected" and no WiFi networks avaiilable. I connect my android device to wifi network and share internet via USB cable (usb0)..

ifconfig, iwconfig does not list any other interfaces except loopback and ethernet. System Settings > Additional Drivers set to "Using Broadcom 802.11 Linux STA Wireless from bcmwl-kernel-source".

What i've tried

apt-get install --reinstall bcmwl-kernel-source.

Doesn't help, as make during this installation fails due to code errors. All i get is sucessfull exit and automatically generated error report to ubuntu..

I've tried solutions like in Qualcomm Atheros AR8172 Driver fix? (lenovo g500s) or http://ubuntuforums.org/showthread.php?t=2103062 or How do I get an Atheros AR8162 working?

They all did not help as i face sirious compile errors with "undefined" macros/symbols or redefinitions, plus many of source download links are dead in this examples. I tried to fix the code but it is impossible to make it.

None of Installing Broadcom Wireless Drivers helped. I see no changes after following any of solutions with rebooting..

I've tried full system reinstall, switched to "OtherOS" optimized options in EFI BIOS, Enabled Legacy Support.

UPDATE How do I get proprietary Broadcom drivers to work after installation?, including installing firmware-b43-installer b43-fwcutter did not help.

sudo apt-get install linux-firmware-nonfree - no effect

Please, point me to any solutions possible...!

lspci -vnn | grep Network output:

07:00.0 Network controller [0280]: Broadcom Corporation BCM43142 802.11b/g/n [14e4:4365] (rev 01)

UPDATE Output of rfkill list all:

0: ideapad_wlan: Wireless LAN
    Soft blocked: no
    Hard blocked: no
1: ideapad_bluetooth: Bluetooth
    Soft blocked: no
    Hard blocked: no
2: ideapad_3g: Wireless WAN
    Soft blocked: no
    Hard blocked: no

3 Answers 3


I just installed 14.04.2 on a system, also with a Broadcom wifi chip, and was having the same issue.

In the past, on a fresh install on this system, I've had to install "dkms" and then "bcmwl-kernel-source" - both of which are available on the Ubuntu install media (under "pool"), and if I install them in that order, I've found that it creates the wireless interface and configures it properly to let me use it. But not this time!

This appears to be an issue with 14.04.2 and the included Broadcom driver (never a good thing to hear), and for me, it happened to be this exact issue reported on Launchpad:


That bug report states a fix was released 9 months ago for this, but for some reason it didn't make it into the 14.04.2 release. The issue didn't affect 14.04.1 since it was still using the 3.13 kernel.

Happily, I was able to fix it easily, by just installing the bcmwl-kernel-source package from Ubuntu 14.10 "Utopic", rather than doing the code editing and compiling that is discussed in the bug report.

You can download the bcmwl package for Utopic from here:


Get the amd64 one if you are using 64-bit, or i386 for 32-bit. Just download it and double-click it - Ubuntu Software Centre will pop up and ask if you want to install it. Hopefully, if your problem is the same as mine, that will automatically install the module, add the wireless interface and get you online without having to tether to your phone.


  • Amazing, it works. Sadly cannot give you +1) You're genius, i was really disappointed why these solutions on forums do not help me in 14.04.
    – Kacap
    Feb 21, 2015 at 21:53
  • Unfortunately, i have to reinstall this package each time after reboot, and then execute modprobe -r b43 ssb wl and then modprobe wl..
    – Kacap
    Feb 21, 2015 at 23:11

Matt's solution did the trick, but after reboot my WiFi interface disappeared again and i had to reinstall package each time, then using modprobe to get it working. So i post here a list of actions i did to get my wifi card working.

Firstly remove packages

sudo apt-get remove bcmwl-kernel-source firmware-b43-installer b43-fwcutter

Now download and install bcmwl-kernel-source with bug fixed:

cd ~/Desktop
wget http://ubuntu.mirrors.tds.net/ubuntu/pool/restricted/b/bcmwl/bcmwl-kernel-source_6.30.223.248+bdcom-0ubuntu1_amd64.deb -O bcmwl.deb
sudo apt-get install dkms
sudo dpkg -i bcmwl.deb

Now turn on the driver. If WiFi will not appear (wlan0 at iwconfig) then something is wrong (try next step and try again modprobes). This appear to work only after bcmwl.deb installation.

sudo modprobe -r b43 ssb wl
sudo modprobe wl

To fix the boot configuration, i had to edit modprobe's blacklist configuration:

gksudo gedit /etc/modprobe.d/blacklist.conf

I post blacklist directives which are required, and commented directives are NOT required for WiFi fix:

#blacklist bcm43xx
blacklist brcmsmac
blacklist bcma

# unsure
blacklist ssb

And finally i had to disable kernel module brcmsmac:

gksudo gedit /etc/modules

Ensure there is no brcmsmac mentioning or it is a comment.


Done, now i can safely reboot with WiFi interface working.


You shouldn't have to install the package every reboot and the install of this package should blacklist b43, ssb, bcma unless they are in /etc/modules and the only reason for wl not to load is because you put it in a blacklist file

Check /etc/modules with cat /etc/modules and you can check blacklist files for wl with `for f in /etc/modprobe.d/*; do echo $f; cat $f | grep wl; done


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.