4

When upgrading from to the new Hardware Enablement Stack manually using this command:

sudo apt-get install --install-recommends linux-generic-lts-utopic xserver-xorg-lts-utopic libgl1-mesa-glx-lts-utopic libegl1-mesa-drivers-lts-utopic

This error comes up:

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 indicator-bluetooth : Depends: unity-control-center but it is not going to be installed or
                                gnome-control-center but it is not going to be installed or
                                ubuntu-system-settings but it is not going to be installed
 libqt5feedback5 : Depends: libqt5multimedia5 (>= 5.0.2) but it is not going to be installed
 libqt5quick5 : Depends: libqt5gui5 (>= 5.2.0) but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

What could be the cause and how can I solve this?

System:

Linux sandsturm 3.13.0-45-generic #74-Ubuntu SMP
  Tue Jan 13 19:36:28 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux
  • did you happen to use intel-linux-graphics-installer at some point? If you don't remember than this could show apt-cache policy libgbm1 libgl1-mesa-dri – doug Feb 21 '15 at 20:04
  • yes, i did. what does this change? – stego Feb 22 '15 at 15:47
  • It makes it impossible to upgrade to the new mesa hwe stack. What you would need to do is replace most of the packages that were acquired from Intel with the current Trusty repo versions. While the versions in trusty-updates & trusty-security are the same the package names aren't the same package names. I give an example here but may not cover your complete situation ubuntuforums.org/… – doug Feb 22 '15 at 16:17
  • askubuntu.com/questions/588558/… Use this answer as an example of what to do – Virusboy Feb 22 '15 at 21:38
2

I had the exact same problem, and this worked for me:

  1. I installed the 14.04 (trusty) versions of those same packages first:

    sudo apt-get install --install-recommends linux-generic-lts-trusty xserver-xorg-lts-trusty libgl1-mesa-glx-lts-trusty libegl1-mesa-drivers-lts-trusty
    
  2. Once I installed those, I was able to run the command to upgrade the enablement stack:

    sudo apt-get install --install-recommends linux-generic-lts-utopic xserver-xorg-lts-utopic libgl1-mesa-glx-lts-utopic libegl1-mesa-drivers-lts-utopic
    
  3. Lastly, a bit of cleanup:

    sudo apt-get autoremove
    

Edit:

After following the above steps, Steam tried to install a couple packages (libgl1-mesa-dri:i386 and libgl1-mesa-glx:i386) and they were failing. I was able to fix it easily:

sudo apt-get install libgl1-mesa-dri-lts-utopic:i386 libgl1-mesa-glx-lts-utopic:i386

I'll have to remember that pattern for packages in the future if they fail installing/upgrading (try adding -lts-utopic to the package name).

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.