0

I'm trying to install MariaDB ob my laptop with Ubuntu 14.10. Every time I'm getting errors. So, the problem is that MariaDB needts libmysqlclient18 version 10.0.16 but 5.x.x is installed. If I'll install 10.0.16 I'll get new error that another app need libmysqlclient18 previous version. I've tried to do the steps that is on the MariaDB installation guide page, but it didn't help. Or maybe I've done something wrong.

ant@ubuntupc:~$ sudo apt-get install mariadb-server
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 libmariadbclient18 : Depends: libmysqlclient18 (= 10.0.16+maria-1~utopic) but 5.5.41-0ubuntu0.14.10.1 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

ant@ubuntupc:~$ sudo apt-get install libmysqlclient18=10.0.16+maria-1~utopic
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  aptitude-common aptitude-doc-en cabextract intltool libaio1 libcwidget3
  libdbd-mysql-perl libdbi-perl libunique-3.0-0 libxml-parser-perl
  linux-headers-3.16.0-23 linux-headers-3.16.0-23-generic
  linux-image-3.16.0-23-generic linux-image-extra-3.16.0-23-generic
  mariadb-client-10.0 mariadb-client-core-10.0 mariadb-server-10.0
  mariadb-server-core-10.0
Use 'apt-get autoremove' to remove them.
The following packages will be upgraded:
  libmysqlclient18
1 upgraded, 0 newly installed, 0 to remove and 38 not upgraded.
5 not fully installed or removed.
Need to get 0 B/2 948 B of archives.
After this operation, 3 478 kB disk space will be freed.
dpkg: error processing archive /var/cache/apt/archives/libmysqlclient18_10.0.16+maria-1~utopic_amd64.deb (--unpack):
 libmysqlclient18:amd64 10.0.16+maria-1~utopic (Multi-Arch: no) is not co-installable with libmysqlclient18 which has multiple installed instances
Errors were encountered while processing:
 /var/cache/apt/archives/libmysqlclient18_10.0.16+maria-1~utopic_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


ant@ubuntupc:~$ sudo apt-get -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  aptitude-common aptitude-doc-en cabextract intltool libaio1 libcwidget3
  libdbd-mysql-perl libdbi-perl libunique-3.0-0 libxml-parser-perl
  linux-headers-3.16.0-23 linux-headers-3.16.0-23-generic
  linux-image-3.16.0-23-generic linux-image-extra-3.16.0-23-generic
  mariadb-client-10.0 mariadb-client-core-10.0 mariadb-server-10.0
  mariadb-server-core-10.0
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  libmysqlclient18
The following packages will be upgraded:
  libmysqlclient18
1 upgraded, 0 newly installed, 0 to remove and 38 not upgraded.
5 not fully installed or removed.
Need to get 0 B/2 948 B of archives.
After this operation, 3 478 kB disk space will be freed.
Do you want to continue? [Д/н] y
dpkg: error processing archive /var/cache/apt/archives/libmysqlclient18_10.0.16+maria-1~utopic_amd64.deb (--unpack):
 libmysqlclient18:amd64 10.0.16+maria-1~utopic (Multi-Arch: no) is not co-installable with libmysqlclient18 which has multiple installed instances
Errors were encountered while processing:
 /var/cache/apt/archives/libmysqlclient18_10.0.16+maria-1~utopic_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
ant@ubuntupc:~$ 
  • I'm not sure, but I seem to remember that you need to install mariadb-client first. – Jos Feb 21 '15 at 13:21
  • did you try to run sudo apt-get autoremove then sudo apt-get update and then sudo apt-get dist-upgrade ? – JoKeR Feb 21 '15 at 13:27
1

It seems you have artifacts from mysql-client library used by another application. I suggest to do

sudo aptitude search libmysql | grep '^i'

This will display the installed versions of libmysql which you could try to remove one by one with apt. It may be possible that one of your installed applications might be dependent on said version and forcefully remove itself in the process.

1

Seems that I found a solution. I've fixed it like typical Windows-user :-) Just removed all the mysql and mariadb packages and installed mariadb then.

0

First, completely get rid of the two conflicting clients:

sudo apt-get –purge remove libmariadbclient1
sudo apt-get –purge remove libmysqlclient18

and then try the mariadb install again. It should work now.

sudo apt-get update
sudo apt-get install mariadb-server-10.1

Finally,

sudo apt-get upgrade

to see that everything is back in order.

taken from http://mikelfox.com/mysql/problems-installing-mariadb-5-5-10-1-on-ubuntu-12-13-14-04-etc/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.