3

When I got this new PC, it had a floppy drive attached. Recently I decided that I wasn't going to need it, ever, and it only made some noise on startup. So I took out the cables connected to it, and it no longer makes noise obviously. Problem solved. But Nautilus still shows the floppy drive in the list of drives, and I can't get rid of it despite it not actually being present. It is also shown on the launcher. Clicking it does nothing. How do I remove these buttons?

This is what sudo fdisk -l gives me:

Disk /dev/sdb: 203.9 GB, 203928109056 bytes
255 heads, 63 sectors/track, 24792 cylinders, total 398297088 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xdc4bdc4b

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1            4096   398297087   199146496   83  Linux

Disk /dev/sda: 120.0 GB, 120033041920 bytes
255 heads, 63 sectors/track, 14593 cylinders, total 234439535 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x000c1b44

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *        2048      499711      248832   83  Linux
/dev/sda2          501758   234438655   116968449    5  Extended
/dev/sda5          501760   234438655   116968448   8e  Linux LVM

Disk /dev/mapper/ubuntu--vg-root: 113.3 GB, 113330094080 bytes
255 heads, 63 sectors/track, 13778 cylinders, total 221347840 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00000000

Disk /dev/mapper/ubuntu--vg-root doesn't contain a valid partition table

Disk /dev/mapper/ubuntu--vg-swap_1: 6442 MB, 6442450944 bytes
255 heads, 63 sectors/track, 783 cylinders, total 12582912 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00000000

Disk /dev/mapper/ubuntu--vg-swap_1 doesn't contain a valid partition table

It doesn't appear to contain any info on floppy drives or missing drives.

And this is what cat /etc/fstab says:

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
/dev/mapper/ubuntu--vg-root /               ext4    errors=remount-ro 0       1
# /boot was on /dev/sda1 during installation
UUID=4ce4e749-7286-46d6-b756-cb09cb51fead /boot           ext2    defaults            0       2
/dev/mapper/ubuntu--vg-swap_1 none            swap    sw              0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto,exec,utf8 0       0

It does say something about a floppy drive, but nothing about it being missing, defunct, or anything like that.

  • what does cat /etc/fstab say in the console? Please include it in your question. – meskobalazs Feb 21 '15 at 13:17
2

First, you should definitely remove your floppy drive from fstab, you can use a simple text editor for this. If this does not solve your problem in itself (it should though), please refer to this old answer for a similar question.

If it is a desktop PC, another option is trying to disable it in the BIOS.

  • I commented the line about /dev/fd0, do I need to reboot for it to take effect? – latias1290 Feb 21 '15 at 13:31
  • Probably a relog is enough, but it won't hurt to reboot. – meskobalazs Feb 21 '15 at 13:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.