6

I am trying to install Ubuntu 14.04.1 (i386-32 bit) dual boot with Windows 7 (home premium 64 bit). I created a USB stick correctly, Checked for md5sum.

After manual option, I created swap, /, /home and proceeded. It gets stuck at detecting file systems.

I tried several times with following options:

  1. enabling wifi (which kept loosing and searching for connection)
  2. wired internet (worked fine (I hope) )
  3. with out internet (I.e without updates)

P.S. I just now un-installed opensuse 11.3 from dual boot with Windows. The memory which was freed from suse is in free space (Light Green) and not unallocated (black). is that a problem?

Alongside I am searching for windows help to convert the green space to black.

Screen shot of gparted from Try Ubuntu

3
  • Have you tried to create /boot and /swap? I'm not really sure but wouldn't hurt to try! Feb 21, 2015 at 5:30
  • Welcome to Ask Ubuntu! ;-) Could you please give us a bit more information like: Boot of an Ubuntu liveCD, use the "Try Ubuntu option", go to the dash (the upper left icon) type gparted and take a screenshot of that and post it somewhere and add the link into your question. Please edit your question to add this information...
    – Fabby
    Feb 22, 2015 at 10:56
  • Thank you. Question edited with gparted information. (Sorry the pictures are taken from camera and are not the screenshots.) Feb 22, 2015 at 12:20

3 Answers 3

3

If I were you, I'd:

  • Take a full system backup
  • Download and burn a DVD of 14.04.2 32 bit version as you seem to have a need for OpenOCD which doesn't seem to like 64-bit versions.
  • boot and follow these instructions,
  • at step 8 take "something else",
  • delete the 200GB /dev/sda6 partition and create a 32GB / and 128 GB /home in ext4 format.
  • leave the rest unallocated (to add to something when that one becomes full somewhere in the future)
3
  • 1
    thanks a lot for your answer. my motive for ubuntu was to use OpenOCD. OpenOCD doesnt work well on 64bit versions. Driver problems. so should i carry out this procedure with 32bit image? (i.e. instead of pen drive i'll use live cd).P.S. this partially answers the que, should i still tick & make it green? Feb 23, 2015 at 8:26
  • There you go: edited. Anything else not answered?
    – Fabby
    Feb 23, 2015 at 9:20
  • :) Happy... thnx i'll try and let you know... every thing answered... :D Feb 23, 2015 at 14:17
2

I encountered the same problem as you when I tried to install Ubuntu 16.04 and Ubuntu 16.10. It was always stuck on Detecting file systems. I found out that the installation program will try to umount the path /isodevice, but the file is held by kernel, so umount fails.

At last, I opened the terminal and ran the command

sudo umount -l /isodevice 

with success. Then I ran the installation program again. The problem did not occur again.

1
  • Just to clarify, you want to look for any mounted partitions by running df, and then for whatever items you see there that are partitions of the drive you're trying to install on, run sudo unmount -l DEVIICE_NAME, where DEVICE_NAME is the value in the first column of the output of of df Oct 31, 2017 at 12:45
0

If u stuck in detecting file ... ( cdrom failed ) Restart os , choose try ubuntu

  1. sudo umount -l /isodevice ( terminal )
  2. Reinstall ---> continue --> something else ( if u want to create manual partition )
  3. just using your " free space " ( if it equal 0 , change from your disk NTFS ( sub it )
  4. Finally , u will have free space create 3 partition ( swap , / , /home ) .
  5. Choose your region time and the rest
1
  • duplicate of the accepted answer
    – karel
    Jun 10 at 2:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.