I have tried some of the solutions posted elsewhere in the support forum, one seemed like it worked but after a steam update i found myself back at square one I am a new Linux user and am already at a learning curve :) Thanks for any help

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libgl1-mesa-glx:i386 : Depends: libglapi-mesa:i386 (= 10.1.3-0ubuntu0.3)
 unity-control-center : Depends: libcheese-gtk23 (>= 3.4.0) but it is not going to be installed
                        Depends: libcheese7 (>= 3.0.1) but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
Press return to continue: 

This is what actually works for 14.04:
sudo apt-get install libc6:i386
sudo apt-get install libgl1-mesa-glx-lts-trusty:i386

Proof: An image of steam working after successful installation Hope this helps others.

  • 1
    worked for me as well+ – Reut Sharabani Sep 14 '15 at 23:00
  • 1
    great :) suggestions to make this answer better are welcomed – JorgeArtware Sep 14 '15 at 23:02
  • That didn't work for me on Ubuntu 14.04.3. :-( – Rafael_Espericueta Oct 3 '15 at 20:54
  • hello Rafael, I keep getting upvotes so I think this post is actually helping others, but I still wonder if you had any luck fixing this issue :) I saw your profile and noticed you're a teacher, teachers get special treatment in my book, let me know if I can help you – JorgeArtware Dec 11 '15 at 17:42

Workaround:

sudo apt-get install libc6:i386 libgl1-mesa-dri-lts-utopic:i386 libgl1-mesa-glx-lts-utopic:i386

The command is a bit different if you are running Ubuntu 14.04.3 or greater with the Hardware Enablement Stack (kernel 3.19):

sudo apt-get install libc6:i386 libgl1-mesa-dri-lts-vivid:i386 libgl1-mesa-glx-lts-vivid:i386
  • Perfect, worked like a charm! – Kirkland Jun 21 '15 at 4:25
  • 8
    The command is a bit different if you are running Ubuntu 14.04.3 with the Hardware Enablement Stack (kernel 3.19): sudo apt-get install libc6:i386 libgl1-mesa-dri-lts-vivid:i386 libgl1-mesa-glx-lts-vivid:i386 – dav.garcia Aug 8 '15 at 21:01
  • this worked for me (Ubuntu 14.04 LTS x86_64: uname -a → 3.16.0-50-generic #67~14.04.1-Ubuntu SMP Fri Oct 2 22:07:51 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux ) – cm-t Oct 16 '15 at 21:13

This is actually a bug. I have already reported this issue on Bugs Launchpad and you can follow it using these two bug-tracker links.

You can fix it manually but it is to complicated. Ubuntu devs will fix it soon so I advise you just wait for updates.

  • You might want to flag this next time as a bug – Virusboy Feb 24 '15 at 0:12
  • It's still not fixed. Perhaps next year... – Rafael_Espericueta Oct 3 '15 at 20:55

For Ubuntu 14.04.3 try this workaround:

sudo apt-get install libc6:i386 libgl1-mesa-dri-lts-vivid:i386 libgl1-mesa-glx-lts-vivid:i386
  • I've been looking everywhere for this! Thank you! – Inoki Oct 8 '15 at 12:16

I found this worked for me perfectly.

sudo apt-get install steam -y

protected by Community Mar 1 '15 at 9:14

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.