1

I have problem with personal edition installation and launch on UBUNTU 14.10 (64bit). Thank you for your advice.

My installation steps:

  1. Downloaded files from lispworks homepage: lwlper-licence.sh, lwlper-install.sh, lwdoc61-x86-linux.tar.gz and finally lwper61-x86-linux.tar.gz ... all files in one folder
  2. set execute attribute on .sh both files
  3. license agreement script: sudo ./lwlper-licence.sh
  4. installation script: sudo ./lwlper-install.sh 5.sudo apt-get install libgtk2.0-dev gtk+-2.0
  5. when i start installed app using command /usr/local//usr/local/lib/LispWorksPersonal/lispworks-personal-6-1-1-x86-linux ---> causes following error
LispWorks(R): The Common Lisp Programming Environment Personal Edition
Copyright (C) 1987-2012 LispWorks Ltd.  All rights reserved.
Version 6.1.1
Saved by LispWorks as lispworks-personal-6-1-1-x86-linux, at 06 Dec 2012 16:51
User jirka on vincent-pc
Error during GUI startup:
  Could not register handle for external module "-lgtk-x11-2.0":
 libgtk-x11-2.0.so: cannot open shared object file: No such file or directory.

DESCRIPTION: Output Backtrace 

IMPACT: Broken/Annoying/Data Loss/Missing Error/New Feature/Performance Loss

URGENCY: ASAP/Current Release/Next Release/Future Release/None

PRODUCT CONFIGURATION:
  LispWorks Personal Edition 6.1.1

Process name: /usr/bin/lispworks
   ID: 10940    Started at: 2015/02/20 18:33:45

Save history:
1: lispworks-6-1-0-0-x86-linux-release-base
Saved by davef as lispworks-6-1-0-0-x86-linux-release-base, at 03 Nov 2011 13:25
2: lispworks-6-1-0-0-x86-linux-release-gtk-shaken
Saved by davef as lispworks-6-1-0-0-x86-linux-release-gtk-shaken, at 03 Nov 2011 14:00
3: lispworks-6-1-1-0-x86-linux-release-gtk-shaken
Saved by davef as lispworks-personal-6-1-1-x86-linux, at 06 Dec 2012 16:51
LispWorks 6.1.1 - Personal Edition

Loaded Modules: 

Public patches: 
Private patches:  CAPI-GTK-DESTROY-REPRESENTATION

Foreign modules:
  #
  #
  #
  #

Signal Handlers
2       SYSTEM::SIGINT-HANDLER
13      SYSTEM::THE-NULL-FUNCTION
17      SYSTEM::GET-CHILDREN-INF

HOST CONFIGURATION:

  vincent-pc (x86_64), Linux 3.16.0-23-generic
  Ubuntu 14.10 \n \l

LWSerialNumber: Unknown
Site: Unknown
GTK+ not loaded

Backtrace:
#

Call to (SUBFUNCTION 1 ENVIRONMENT:START-ENVIRONMENT) {offset 186}
  SYSTEM::C : #

Binding frame:
  CONDITIONS::*IN-SIGNAL-CATCH* : T

Handler frame: NIL
Call to SIGNAL {offset 1446}
  CONDITIONS::DATUM     : #
  CONDITIONS::ARGUMENTS : NIL

Binding frame:
  CONDITIONS::*IN-SIGNAL-CATCH* : NIL

Catch frame: CONDITIONS::SIGNAL-CATCH

Binding frame:
  CONDITIONS::*BROKEN-ON-SIGNALS* : NIL

Call to CONDITIONS::CONDITIONS-ERROR {offset 430}
  CONDITIONS::DATUM     : "Could not register handle for external module ~S:~% ~A."
  CONDITIONS::ARGUMENTS : ("-lgtk-x11-2.0" "libgtk-x11-2.0.so: cannot open shared object file: No such file or directory")

Call to ERROR {offset 67}
  SYSTEM::ESTRING : "Could not register handle for external module ~S:~% ~A."
  SYSTEM::EARGS   : ("-lgtk-x11-2.0" "libgtk-x11-2.0.so: cannot open shared object file: No such file or directory")

Binding frame:
  FLI::*DLOPEN-FLAGS* : T

Call to FLI::CONNECT-TO-EXTERNAL-MODULE {offset 319}
  FLI::MODULE : #
  TYPE        : :MANUAL
  FLI::ERRORP : T

Call to FLI::CREATE-EXTERNAL-MODULE {offset 275}
  FLI::NAME             : "-lgtk-x11-2.0"
  FLI::CONNECTION-STYLE : :IMMEDIATE
  FLI::FILENAME         : NIL
  FLI::MODULE           : #
  OPEN                  : T
  FLI::LIFETIME         : :SESSION
  FLI::DLOPEN-FLAGS     : FLI::DEFAULT
  FLI::ADD-LIB-PATH     : NIL

Call to FLI:REGISTER-MODULE {offset 146}
  FLI::NAME             : "-lgtk-x11-2.0"
  FLI::CONNECTION-STYLE : :IMMEDIATE
  FLI::LIFETIME         : :SESSION
  FLI::REAL-NAME        : NIL
  FLI::FILE-NAME        : NIL
  FLI::DLOPEN-FLAGS     : FLI::DEFAULT
  FLI::ADD-LIB-PATH     : NIL

Call to LWGTK:INITIALIZE-GTK-LIBRARY {offset 999}

Call to CAPI-GTK-LIBRARY::ENSURE-GTK-INITIALIZED {offset 21}

Call to (METHOD CAPI-LIBRARY:LIBRARY-READY-TO-START ((EQL :GTK))) {offset 11}
  CAPI-GTK-LIBRARY::LOOK-AND-FEEL : :DONT-KNOW

Call to CLOS::CACHE-MISS-FUNCTION {offset 311}
  CLOS::ARGS                   : (:GTK)
  CLOS::.CACHE-INFO.  {Closed} : #
  CLOS::.GF.  {Closed}         : #

Call to CAPI-INTERNALS:START-ENVIRONMENT {offset 60}
  CAPI::ARGS            : (:START-FUNCTIONS ((LISPWORKS-TOOLS::START-LISPWORKS-TOOLS :TOOLS (LISPWORKS-TOOLS:LISPWORKS-ECHO-PODIUM LISPWORKS-TOOLS:LISTENER))) :ENVIRONMENT :CAPI)
  CAPI::ENVIRONMENT     : :CAPI
  PACKAGE               : NIL
  CAPI::LIBRARY         : NIL
  CAPI::START-FUNCTIONS : ((LISPWORKS-TOOLS::START-LISPWORKS-TOOLS :TOOLS (LISPWORKS-TOOLS:LISPWORKS-ECHO-PODIUM LISPWORKS-TOOLS:LISTENER)))

Call to ENVIRONMENT::START-CAPI-ENVIRONMENT {offset 24}
  LISPWORKS-TOOLS::ARGS : NIL

Call to CLOS::CACHE-MISS-FUNCTION {offset 311}
  CLOS::ARGS                   : (# NIL)
  CLOS::.CACHE-INFO.  {Closed} : #
  CLOS::.GF.  {Closed}         : #

Handler frame: ((ERROR . #))
Call to ENVIRONMENT:START-ENVIRONMENT {offset 158}
  SYSTEM::ARGS          : NIL
  SYSTEM::OLD  {Closed} : #

Binding frame:
  MP:*INITIAL-PROCESSES* : (("The idle process" (:PRIORITY -536870912 :RESTART-ACTION :CONTINUE :INTERNAL-SERVER :IDLE) MP::PROCESS-IDLE-FUNCTION))

Call to ENVIRONMENT::I-RESTART-WITH-ENVIRONMENT-AUX {offset 210}
  ENVIRONMENT::TTY-LISTENER-P : NIL

Call to SYSTEM::RESTART-HOOK {offset 96}
  FUNCTION : SYSTEM::%TOP-LEVEL

Restart frame: (SYSTEM::TOP-LEVEL)
Catch frame: (SYSTEM::IN-START-FUNCTION-ONCE . RESTART-CASE)
Catch frame: (SYSTEM::IN-START-FUNCTION-ONCE . 1)
Catch frame: SYSTEM::EXIT-LISPWORKS
Call to SYSTEM::IN-START-FUNCTION-ONCE {offset 421}
Catch frame: SYSTEM::START-UP
Catch frame: SYSTEM::IN-START-FUNCTION
Call to SYSTEM::IN-START-FUNCTION {offset 57}
Call to SYSTEM::CALL-IN-START-FUNCTION {offset 12}
Catch frame: (NIL)

Call to SYSTEM::START-FUNCTION {offset 50}
  SYSTEM::GC-MESSAGES : :DONT-KNOW


SYSTEM::START-FUNCTION

 Generation 0:  Total Size 515K, Allocated 386K, Free 120K 
          Segment 20090128: Total Size 507K, Allocated 386K, Free 117K
                    minimum free space 64K, 
                      Awaiting promotion = 0K, sweeps before promotion =10
          Segment 21EDE100: Total Size 7K, Allocated 0K, Free 3K
                    minimum free space 0K, 
                      Awaiting promotion = 0K, sweeps before promotion =2
 Generation 1:  Total Size 308K, Allocated 110K, Free 189K 
          Segment 2070F0C0: Total Size 68K, Allocated 0K, Free 64K
                    minimum free space 3K, 
                      Awaiting promotion = 0K, sweeps before promotion =4
          Segment 200540A8: Total Size 240K, Allocated 110K, Free 125K
                    minimum free space 0K, static
 Generation 2:  Total Size 68K, Allocated 0K, Free 64K 
          Segment 20F1C640: Total Size 68K, Allocated 0K, Free 64K
                    minimum free space 117K, 
                      Awaiting promotion = 0K, sweeps before promotion =4
 Generation 3:  Total Size 30387K, Allocated 30247K, Free 128K 
          Segment 2010F0C0: Total Size 6144K, Allocated 6139K, Free 0K
                    minimum free space 3K, 
                      Awaiting promotion = 0K, sweeps before promotion =10
          Segment 20F2D6B8: Total Size 16066K, Allocated 15934K, Free 128K
                    minimum free space 0K, 
                      Awaiting promotion = 0K, sweeps before promotion =10
          Segment 20720138: Total Size 8177K, Allocated 8173K, Free 0K
                    minimum free space 0K, 
                      Awaiting promotion = 0K, sweeps before promotion =10

Total Size 31616K, Allocated 30744K, Free 502K
  • sudo apt-get install libgtk2.0-0:i386 solves the problem :-) – Jiří Doubravský Feb 20 '15 at 17:50
  • @Mudit: please review my additional edits. – Fabby Feb 20 '15 at 18:55
  • 1
    Jiří: Instead of putting a comment in here, could you please put that in the answer section? If you found the solution yourself, you should also get the credit! ;-) – Fabby Feb 20 '15 at 18:56
3

Installing libgtk2.0-0:i386 solves the problem, lispworks is old and not 64bit compilant, so it needs i386 version of gtk2 libraries

sudo apt-get install libgtk2.0-0:i386

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.