I have just installed Ubuntu 14.04.2 LTS on my Lenovo-G50-30 laptop, replacing Windows 8. 'Enable wifi' is greyed out. Typing rfkill list all in the terminal tells me that

0: ideapad_wlan: Wireless LAN
Soft blocked: no
Hard blocked: yes
3: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no

So the problem is presumably that ideapad_wlan is hard blocked. 'sudo rfkill unblock all' doesn't change this. There seems to be no switch on the laptop itself, nor are any of the F keys relevant.

How do I enable WiFi?

  • Have you tried Fn + F7? – Mitch Feb 20 '15 at 13:15
  • "hard blocked" means what it says: -hardware- is blocking your wifi. So ... either you have a slider on the side of your notebook or you have a keyboard combination (like Fn F7 Mitch suggested) or you have a BIOS setting where wifi is disabled. As far as I know that are probably all the options. So if the 1st 2 are checked you could check your BIOS for a block ;) – Rinzwind Feb 20 '15 at 13:22
  • I found configuration by pressing esc as soon as the computer started turning on. All wireless devices were already enabled. – Raffles Feb 20 '15 at 14:54

Sometimes this can be fixed by blacklisting the ideapad_laptop module with echo "blacklist ideapad_laptop" | sudo tee /etc/modprobe.d/ideapad.conf and rebooting If it doesn't work the blacklist can be removed with sudo rm /etc/modprobe.d/ideapad.conf There is a fix being worked on and addition models being added and some models are fixed in the Utopic 3.16.0-30 kernel

Dmitry Tunin has made a kernel with the fix if you want to try it, a link from the bug report https://bugs.launchpad.net/ubuntu/+source/linux-lts-utopic/+bug/1397021/comments/6

  • This made no difference unfortunately. – Raffles Feb 20 '15 at 14:54
  • Can you add the results of cat /sys/class/dmi/id/product_name as I might be able to modify the source code – Jeremy31 Feb 20 '15 at 15:34
  • cat /sys/class/dmi/id/product_name gives 80G0 – Raffles Feb 20 '15 at 16:51
  • I should also add that the documentation (for use with windows 8) includes turning off airplane mode via f7. Pressing f7 or fn+f7 gives no response and doesn't change anything. Bluetooth is also hard blocked, if that is relevant. – Raffles Feb 20 '15 at 17:05
  • Airplane mode is off I have confirmed, and Bluetooth is also hard blocked. On settings-->network, it is possible to drag the bluetooth slider into the 'on' position, but impossible to drag the wireless slider into the 'on' position (it just snaps back). – Raffles Feb 20 '15 at 17:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.