So I have a desktop that I have been Using as a way over the top Media Center (specs at paste bin).

I have successfully run 10.04 and 10.10 on this system with only a bit of shenanigans with pulse audio to smooth things out.

However with 11.04 and now 11.10 I have not been able to boot passed grub all I get is a blinking cursor. I believe it is a problem with the kernel but I don't know what to do about it.


I ran a verbose boot from live USB and cd and it stops at this line in aprox 3.8 seconds in to the boot

ohci_hcd 0000:00:12.1: irq 16, io mem 0xfe02d000
  • 1
    11.10 is still in development as you should know, on 11.04 you can still use older kernels if that's what is causing problems. Aug 26 '11 at 15:42
  • Is there any thing in specific about the hardware I have which is "upsetting" the newer kernels is there any tests I can use to collect relevant information about why the kernel isn't booting?
    – Allan
    Aug 26 '11 at 16:18
  • Is this issue still affecting you? Do you think more information can be added to this question? If not can this question be considered abandoned? Dec 10 '11 at 20:44
  • This question seems abandoned, there is not further information or activity added to it for several months. I am flagging this to be closed by a moderator. If you think this issue is still affecting you you can flag a moderator to re-open it. Feb 9 '12 at 14:51
  • Hi Bruno I've been really busy recently I need to get in contact with the kernel team to find out what they think is the problem I will see if I can do that this weekend if nothing is forthcoming I will remove the question myself
    – Allan
    Feb 10 '12 at 11:29

Here is a thread from the Ubuntu Forums that may help; there's tons of info in there: Graphics Resolution- Upgrade /Blank Screen after reboot

  • 2
    Please give a short summary of that thread so that readers know what they can expect.
    – Lekensteyn
    Aug 26 '11 at 17:51
  • Added a summary Dec 16 '11 at 4:13
  • 1
    Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference.
    – Marco Ceppi
    Dec 16 '11 at 4:15
  • The thread is enormous, but I'll see what I can do. Dec 16 '11 at 4:18

@grahammechanical provided a link to a thread at the Ubuntu Forums, so first I thank him for that.

Graphics Resolution - Upgrade / Blank Screen after reboot

Are you having these problems?

  • "Cannot display this grahics mode"
  • GRUB_GXFMODE - auto results in blank screen problems on Startup? (this includes purple or black screen, flashing cursor, stuck at splash screen...)
  • No grub menu?

The post contains a pretty exhaustive list of keyboard shortcuts to help diagnose graphics problems on Linux systems, e.g.


Switch to the first text terminal. Under Linux you can have several (6 in standard setup) terminals opened at the same time. Terminals start as tty0 and go up from there. Most of the time the normal boot text console, that is present "under" the GUI or Xsession (in Ubuntu) is tty1, so you would press to get to it...


Switch to the first GUI terminal (if X-windows is running on this terminal).

There's also a short troubleshooting flow chart:

  1. Do you have a grub menu?

    • Yes: Go to step 2.
    • No: While booting, Press shift key multiple times (don't hold it down) to see if the Grub menu will come up
      • If you get the menu now, go to step 2
      • If still no menu, comment out GRUB_HIDDEN_TIMEOUT=00 in /etc/default/grub/ and rerun grub-update from a LiveCD.
        • If you get the menu now, go to step 2
        • If still no menu, reinstall grub and start over from step 1, because it seems that grub is not booting.
  2. Does the Linux kernel boot?

    At Grub Menu, go into edit mode and boot into a text console

    • Yes it boots: Go to step 3
    • No it fails to boot: Messages will be verbose on what is loading, what are warnings and what are error messages. Shortcut keys will start to work as the kernel modules load. If it stops at an error, you will be able to use the shortcut navigation cuts to review the errors. If it is a kernel error, you may be able to reinstall or renew the kernel image. If it is a device module problem, at least you have somewhere to go to reload that device module or driver. The goal is to get a "booting kernel."
  3. From the Grub Menu, try to boot in Rescue mode/low graphics.

    • Yes it boots: look for additional drivers and install recommended driver.
    • No it fails to boot: go to step 4 to verify that the Linux kernel will boot.
  4. Can you boot a graphical X session from a text console session?

    From the command line type:

    sudo service gdm start

    • Yes I get a graphical X session: No black screen, no problem; it should boot straight from the grub menu.
    • No it fails to load: Reboot and start testing and changing gfx_modes and kernel boot graphical modes, still booting into the text console before you try to start an X session. Going this way, you will have more of a chance to be able to toggle between a graphical session or text terminal session (sometimes). At a text console, at least you have the ability to install files and make changes to config files, and if you can get back into a command prompt, you could then stop the gdm service that is locked.

    You can stop the gdm service via

    sudo service gdm stop

There's even a table of contents post that can help find the post in the thread that might help your particular situation.

Again, this all comes from a thread at the Ubuntu Forums.

Not the answer you're looking for? Browse other questions tagged or ask your own question.