I would like to access phpmyadmin. I have access it before but, now, I'm just getting a blank page and I really don't get why.

I've installed phpmyadmin using

sudo apt-get install phpmyadmin

I've run

sudo gedit /etc/apache2/apache2.conf

And there added:

#Include phpmyadmin: 
 include /etc/phpmyadmin/apache.conf

But I was getting a warning when I restart apache, telling me:

The Alias directive in /etc/phpmyadmin/apache.conf at line 3 will probably never match because it overlaps an earlier Alias.

How can I solve this, so that I can see phpmyadmin interface again, when I do http://localhost/phpmyadmin instead of seeing a blank webpage?

Dump -

  • I've tried apt-get remove phpmyadmin and then apt-get install phpmyadmin - still the same blank page. :(

  • /etc/phpmyadmin - I've chmod o+w permissions to phpmyadmin folder and it's contents. - still the blank page...

  • Did you try it before you added include /etc/phpmyadmin/apache.conf? If not, can you try to remove that line and restart to try again? Aug 26 '11 at 13:39
  • @root45 - Yes I've try it before without that line. And then with it, and now, I've remove that line. :(
    – MEM
    Aug 26 '11 at 13:49
  • I should have asked this above, but did removing that line get rid of the message "The Alias directive in /etc ... an earlier Alias" that you get when you restart? I think there may be two separate issues here. Aug 26 '11 at 14:21
  • @root45 - Yes. Removing that line, removed the message.
    – MEM
    Aug 26 '11 at 15:02
  • 1
    @root45: ls -ld /etc/phpmyadmin is the right way to get a single line of information on a folder.
    – Lekensteyn
    Aug 27 '11 at 8:47

All the previous answers did not help me, but then I found the solution:

apt install php-gettext

this fixed phpmyadmin white blank page issue.

  • 2
    After updating from 15.04 to 16.04, I needed to re-install MySQL 5.7 because the attempted upgrade from MySQL 5.6 failed. After the 5.7 installation, I got a blank page from phpMyAdmin also... spent a great amount of time searching for clues... and this single answer resolved my issue. Thanks.
    – TheGeeko61
    May 22 '16 at 16:08

Try running

sudo dpkg-reconfigure phpmyadmin

To set up the phpmyadmin files, database connections and create the phpmyadmin databases

  • I cannot test this any longer. If someone find this answer an answer, please shared and I will mark it as a correct answer. cheers.
    – MEM
    Nov 11 '11 at 18:30
  • 1
    Not working on 15.04 problem still remained. May 18 '15 at 11:58

This problem occurred to me because I modified the php.ini (/etc/php5/apache/php.ini) and introduced a wrong format. Specifically, I needed to upload a bigger file so I modified this line:

upload_max_filesize = 2M


upload_max_filesize = 20

As you can see, I missed an M. After restarting apache (sudo service apache2 restart), I was getting the blank page.

** In general, it might be that a mistake in the php.ini produces a silent (blank page) output in php. **


An old question I know, but I recently had the same problem. Accessing the phpmyadmin url produced a blank white page. The apache logs showed nothing wrong. All response headers were "200 OK".

The problem was simple, I had disabled javascript in the browser.

To fix in firefox, enter the url 'about:config', find the key named 'javascript.enabled' and toggle it true.

In chrome, navigate to Setting > Advanced Settings > Content Settings, scroll down to the Javascript header and toggle the 'Enable javascript' checkbox.


When i changed this inside the config.inc.php:

$cfg['UploadDir'] = '/tmp'; $cfg['SaveDir'] = '/tmp';


$cfg['UploadDir'] = ''; $cfg['SaveDir'] = '';

and reloaded the page then it worked directly!


My problem was different: the page rendered white but, inspecting the HTML, I could see the login and password fields. The problem was in the space on the HDD:

No space left on device

Freeing some made phpMyAdmin work again.


I`m not sure if is the same in ubuntu, but for debian 7.0.0 i find a way and my problem was fixed with this :

apt-get install php5-json

I informed from this link :


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.