1

I'm trying to install Ubuntu 14.10 x64 on my laptop. But I always get "booting in insecure mode" message and then nothing happens. My laptop has BIOS Legacy not UEFI. There's any option about security on BIOS beside BIOS password. My laptop had Ubuntu 14.04 x64 and Windows 8.1 x64 installed, so I wanted upgrade Ubuntu to 14.10 performing a clean installation.

So, how do I solve this error?

2

It is available in Ubuntu14.10 release notes that SecureBoot is disabled for UEFI system, You can refer the below release note

An update to shim in 14.10 introduces a bug where, when booting on a UEFI system with SecureBoot disabled, the boot is delayed for two seconds and a message "Booting in insecure mode" is displayed on the screen. This message does not indicate a security problem with Ubuntu and does not interfere with the operation of the system except for introducing this boot delay. As a workaround to avoid this boot delay, users can enable SecureBoot if enabled on their hardware, or if they do not intend to use SecureBoot at all they can uninstall the shim-signed package and then rerun the grub-install command. 1384973

|improve this answer|||||
0

I got it. I guess my laptop has some kind of hybrid BIOS+UEFI/EFI sistem because it only accepts UEFI/EFI Ubuntu's installation.

The cause of the problem was this Shim + SecureBoot bug. So I did this:

1) Disable FastBoot and Hibernation on Windows 8.1 2) Disabe QuickBoot on BIOS

Then I still get the "booting in insecure mode" message, but only for 2 seconds after that it continues booting.

|improve this answer|||||
0

Message "boot in insecure mode” is not an error. Just follow the thread:

Ubuntu: "Booting in insecure mode" with SecureBoot enabled

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.