5

I am looking for a way to swap the 'tap' action when using two and three fingers. At the moment, as standard, double-finger-tapping right clicks, and tripple-finger-tapping middle clicks ... I would like to switch these two actions, while retaining the two-finger scrolling.

This makes sense to me because I use middle click a lot, and also middle clicking with two fingers correlates with scrolling with two fingers (on a traditional mouse, scrolling is done with the middle wheel).

3

To fix the middle click you can use the following command:

xinput set-int-prop NN 266 8 2 3 0 0 1 2 3

Where NN is the id of the mousepad device, you can see it with the command xinput list. 266 is the id of the property "Synaptics Tap Action" you can see it with xinput list-props NN

You have to run this command every time you boot/login/wake.

To make it permanent you can put this command to the end of your .profile file in your home folder. (You can also try to put it in /etc/init.d/rc.local, but in my case it didn't work.)

  • it is not recommended to put the numbers 266, 8, etc in the command put into .profile. Instead, directly put the property name, surrounded by quotes (either single or double is fine). The reason is the numbers, especially those of the properties, sometimes changes over reboots. – xdavidliu Jul 11 '19 at 22:00
3

Try:

 synclient TapButton2=3 {Two Finger tap}
 synclient TapButton3=2 {Three finger tap}

Or just change the numbers to 2 and 3 as I don't know what default numbers are applied by ubuntu, to see what supports your need. You may also need synclient VertTwoFingerScroll=1 to check two finger scrolling. If this temporary setting gets you to what you want. Go to /usr/share/X11/xorg.conf.d and edit the file 50-synaptics.conf with something like this:

Section "InputClass"
 Identifier "touchpad catchall"
 Driver "synaptics"
 MatchIsTouchpad "on"
 MatchDevicePath "/dev/input/event*"
             Option "TapButton1" "1"
             Option "TapButton2" "2 or 3" what worked for you
             Option "TapButton3" "2 0r 3" what worked for you
             Option "VertTwoFingerScroll" "on"
EndSection

Further instructions on touchpad configuration here and here

P.S: These settings are for synapticstouchpad i.e xserver-xorg-input-synaptics

0

It should be:

 synclient TapButton2=2 
 synclient TapButton3=3 

Somehow the default settings got mixed up to be 2=3 and 3=2 somewhere around Ubuntu 11.04 if I remember correctly. There were bugreports about it at the time, but it has never been fixed.

Luckily it's easy to fix it yourself by putting above mentioned lines in a startup script.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.