1

Why can't resolvconf generate dns-server or how to troubleshoot it?

root@openstack-controller-01[Standby]:/home/user01# cat /etc/resolv.conf 
# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
#     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
root@openstack-controller-01[Standby]:/home/user01# 

I configured /etc/network/interfaces as follows.

auto lo
iface lo inet loopback

auto eth0
iface eth0 inet manual
  bond-master bond0

auto br-ex
allow-ovs br-ex
iface br-ex inet static
  address 172.25.53.61
  netmask 255.255.0.0
  gateway 172.25.0.1
  dns-nameservers 8.8.8.8
  ovs_type OVSBridge
  ovs_ports br-ex
  ethtool -K bond0 gro off
  pre-up ifup bond0
  post-up ovs-vsctl add-port br-ex bond0
  post-down ifdown bond0

auto bond0
iface bond0 inet manual
  up ip address add 0/0 dev $IFACE
  up ip link set $IFACE up promisc on
  down ip link set $IFACE down promisc off
  down ifconfig $IFACE down
  slaves none
  xmit-hash-policy layer2+3
  ovs_bridge br-ex
  ovs_type OVSPort
  pre-up ifup eth0
  post-down ifdown eth0

auto eth1
iface eth1 inet manual
  bond-master bond1

auto bond1
iface bond1 inet static
  address 192.168.1.61
  netmask 255.255.255.0
  xmit-hash-policy layer2+3
  slaves none
  pre-up ifup eth1
  post-down ifdown eth1

And then, I confirmed other node.
It set only bonding configuration.

auto bond0
iface bond0 inet static
        address 192.168.0.5
        netmask 255.255.255.0
        network 192.168.0.0
        broadcast 192.168.0.255
        gateway 192.168.0.254
        # dns-* options are implemented by the resolvconf package, if installed
        dns-nameservers 8.8.8.8
        dns-search local.mki
        slaves eth0
        xmit-hash-policy layer2+3

auto eth0
iface eth0 inet manual
        bond-master bond0


auto bond1
iface bond1 inet static
        address 192.168.1.5
        netmask 255.255.255.0
        slaves eth1
        xmit-hash-policy layer2+3

auto eth1
iface eth1 inet manual
        bond-master bond1

This node has correct nameserver settings.

root@openstack-compute-01:/home/user01# cat /etc/resolv.conf 
# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
#     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
nameserver 8.8.8.8
search local.mki
root@openstack-compute-01:/home/user01# 

I thought this is related to openvswitch, but I don’t know for sure.
Please let me know if you have any knowlede.

Many Thanks.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.