1

Ever since Thunderbird+Lightning offers immediate bilinear contact with Google Calendar, I have been using it. But there seems to be a problem in my Ubuntu 14.04 installation: Google provider is not working. In fact, Lightning is not allowing me to connect to my Google Calendar account whatsoever!

So when trying to configure my Google calendars, I first try to add a network calendar, then I pick Google:

enter image description here

At this stage I would hope for the "location" input to disappear so that I could use an open session. This is how it works in my other Thunderbird settings (in a Fedora and Mac I have at work) and is how I wanted it to work in the first place. But as it is not working, I then proceed to input my email address, but alas:

enter image description here

As you can see it does not accept it, and so I cannot use the Lightning extension.

I'm running:

⠀Thunderbird 31.40
⠀Lightning 3.3.4
⠀Google provider 0.32

1

Do you use Lightining and Provider for Google Calendar addons from Ubuntu repositories or from Thunderbird addons repository on https://addons.mozilla.org/it/thunderbird/?

Try to remove both packages from Ubuntu repositories and install both Lightning and Provider fo Google Calendar from https://addons.mozilla.org/it/thunderbird/ and try again.

Recently authentication model for Google Calendar has changed, and you need updated addons to make it work.

  • 1
    Thank you! This worked as intended! I was indeed using the repository packages and, namely, the provider was WAY outdated. – romanovzky Feb 19 '15 at 14:45
0

To use Google Calendar in location box you have to paste a XML private URL to your calendar. Go to http://google.com/calendar, click down arrow on the right of your calendar name and open calendar settings. Now copy private XML calendar URL and paste it in location box in Lightning

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.