0

Recently I had Ubuntu 14.04 LTS installed due not liking windows 8 and had trouble installing windows 7 Btw complete newb on Ubuntu ! My problem is that the wifi connection is horrible I cannot connect at all! But did manage to have a connection when it was first installed then after that just didn't connect anymore

I've tried:

  1. Deleting the wifi profile and reconnect
  2. Reset network manager

Don't know what else to do.

Network card
     description: Ethernet interface 
       product: RTL8111/8168/8411 PCI Express Gigabit Ethernet controller 
       vendor: Realtek Semiconductor Co., Ltd. 
       physical id: 0 
       bus info: pci@0000:01:00.0 
       logical name: eth0 
       version: 10
       serial: 28:d2:44:f7:a7:30
       size: 10Mbit/s 
       capacity: 1Gbit/s 
       width: 64 bits 
       clock: 33MHz 
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet     physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000 bt 1000bt-fd autonegotiation 
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=Half firmware=Rtl8168g-3_0.0.1 04/23/13 latency=0 link=No multicast=yes port=MII speed=10Mbit/s 
       resources: irq:60
       ioport:4000(size=256) memory:c0504000-c0504ddd memory:c0500000-c0503fff 
  *-network 
       description: Wireless interface 
       product: RTL8723BE PCIe Wireless Network Adapter 
       vendor: Realtek semiconductor Co.,Ltd.
       physical id: 0 
       bus info: pci@0000:02:00.0 
       logical name: wlan0 
       version: 00
       serial: 10:08:b1:71:65:59
       width: 64 bits 
       clock: 33MHz 
       capabilities: pm msi pciexpress bus_master cap_list rom ethernet physical wireless 
       configuration: broadcast=yes driver=rtl8723be driverversion=3.13.0-45-generic    firmware=N/A ip=192.168.1.66 latency=0 link=No multicast=yes wireless=IEEE 802.11bgn 
       resources: irq:19 
       ioport:3000(size:256) memory:c0400000-c0403fff
0

add this option in kernel drivers settings

$ sudo echo 'options iwlwifi 11n_disable=1' >> /etc/modprobe.d/iwlwifi.conf

Then restart the system this must fix wifi problem.

2
  • How would that work when the person does not even have that driver? – Wild Man Feb 19 '15 at 7:09
  • Yeah I was going to say I can't even find the kernel driver. – teaaa Feb 19 '15 at 12:09
-1
echo "options rtl8723be fwlps=N ips=N" | sudo tee /etc/modprobe.d/rtl8723be.conf

used this code line +restarted laptop and now my wi-fi connection is stable :)

2
  • Could you expand on this a bit? Your answer is showing up in the low-quality queue. Perhaps adding how to get into the terminal and citing a source would do the trick. Thank you! – Elder Geek Feb 19 '15 at 17:39
  • If you give someone a fish, he will not be hungry for a day. If you teach him to fish, he will not be hungry for the rest of his life. Please explain what you're doing here and why... – Fabby Feb 19 '15 at 22:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.