1

There seem to be two microphones detected by my system. The one that is selected by default doesn't work. I found an app called indicator-sound-switcher which allows me to switch to the other mic which does work but I have to do that every time I log out or reboot.

When I go to the input tab of the sound settings, it seems that the default microphone (not working) is called "Internal Microphone" and the other (working) is called "Microphone".

If I use pavucontrol, it shows both microphones. If I deselect the "set as default" button on the Internal Microphone, it is automatically reselected by the next time I switch to that microphone.

I don't have any microphone plugged in. Just the built-in one on my laptop.

I'm not sure where to start looking for clues as to how to fix this. Any help would be appreciated.

I'm running 14.04.

0

Basically follow the way described here.

Determine which device it is working through. run

gstreamer-properties

And test all the ALSA mics. Find one that works. It should be something like hw:1,1 or hw:0,1 and so on. Than edit the /etc/pulse/default.pa accordingly

| improve this answer | |
  • My problem seems to be fixed. I can't say the above fixed it but it is working. I tried editing the default.pa and played with the instructions at the link until I started getting an error saying "No PulseAudio daemon running, or not running as session daemon". Once that happened, my problem stopped. I don't believe in the end I have made any changes to the default.pa. – Ron Collins Feb 20 '15 at 16:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.