2

I am running Ubuntu Gnome 14.04 LTS, Gnome Classic and I want to turn off the auto-maximizing of windows that occurs when I drag a window to the top of the screen. I admit to being confused about the functionality and meaning of compiz, metacity, gconf-editor, etc., but I have tried to follow the instructions that worked for other people with this same problem, and none of them has worked.

I tried using Compiz Configuration Settings Manager (CCSM) to change the Top Edge behaviour from "maximize" to "None" as described in Turning off auto-maximizing of windows in 14.04. I also used gconf-editor to set top_edge_action to 0, as described in How to turn off Compiz's "drag to maximize" behaviour? . I also used CCSM to uncheck "Maximize Vertically if Screen edge hit" as described in How to disable the auto resizing of Windows when you touch the top or bottom. I set the Grid Snapback Threshold to 0 for the top edge in CCSM and top_edge_threshold to 0 in gconf-editor (this was my idea; I don't know if it makes sense or not). Finally I used CCSM to disable the "Grid" feature entirely. At each step there was no change in behaviour and now I find myself stuck with this annoying feature. What else can I try?

  • Personally, I consider this a feature. – Elder Geek Feb 18 '15 at 18:31
2

I use 16.04 Gnome Classic, metacity.

Managed to disable the irritating 'auto resize' problem:

  1. Open 'dconf Editor' ;

  2. Search for edge-tiling

  3. Uncheck the corresponding box.

0

I think the hotcorners tool in Unity Tweak Tool may work for you:

Hotcorners

Disclaimer: I have never used this app, so I am not entirely sure what its features are.

  • That looks like exactly what I want, but unfortunately, that's for Unity; I'm using the Gnome Classic desktop. – kpb Feb 19 '15 at 20:47
0

I am running a similar config, with Gnome Classic, and hit the same problem.

Guesswork led to this gconf-editor solution. Change

/apps/compiz-1/plugins/snap/screen0/options/avoid_snap [0]

to

/apps/compiz-1/plugins/snap/screen0/options/avoid_snap [1]
  • Don, I wanted to comment on your answer, but I lost my Stack Exchange password and had to reset my account. As a result, I do not have the permissions required to add a comment. So here is my response: I tried your solution, but it did not work for me. Thanks anyways. – kpb Jun 24 '15 at 18:33
0

Use the keyboard shortcuts for window positioning instead of the mouse.

CTRL-ALT-(Numpad)8 for window to top, CTRL-ALT-(Numpad)2 for window to bottom, etc.

For more search for the question regarding keyboard shortcuts in Ubuntu.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.