1

My printer is being recognized, installed.

When I am trying to print anything it's saying

"Document Printed"

and

"Documnt has been sent for printing"

but nothing is actually printed.

I've tried CANON LBP printers and HP LaserJet 1020

2
  • have you checked to make sure your printer is set as the default? It may be printing to some other device... – Rory Alsop Aug 26 '11 at 7:44
  • @Rory Alsop, sure I checked. – bakytn Aug 26 '11 at 7:47
2

Do you have printer drivers installed?

My laserjet worked initially on ubuntu 11.10 but stopped working after an update. Then I started getting exactly the same kind of error you described and tried a few things before I got it working.

Try these commands.

hp-setup 

This will help find and install the printer.

Then I used

system-config-printer

I found multiple installations for HP-Laserjet-1020 on my system.. tried printing test pages from all. I kept the printer profile that worked as default and deleted others.

2

You can also configure your printer via CUPS http://localhost:631/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.