1

This question already has an answer here:

Keep trying to update Ubuntu 12.04 but it keeps telling me that my package system is broken. I run apt-get -f install and get this :

    owner@MyLaptop:~$ sudo apt-get -f install
[sudo] password for owner: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  thunderbird-globalmenu linux-headers-3.5.0-34-generic
  linux-headers-3.5.0-32-generic compiz-plugins compiz-plugins-main
  python-compizconfig python-central linux-headers-3.5.0-23
  linux-headers-3.5.0-32 linux-headers-3.5.0-34 linux-headers-3.5.0-23-generic
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  indicator-session
The following packages will be upgraded:
  indicator-session
1 upgraded, 0 newly installed, 0 to remove and 399 not upgraded.
4 not fully installed or removed.
Need to get 0 B/75.8 kB of archives.
After this operation, 0 B of additional disk space will be used.
Do you want to continue [Y/n]? Y
dpkg: warning: parsing file '/var/lib/dpkg/status' near line 12465 package 'indicator-session':
 `Depends' field, reference to `libcairo2':
 `>' is obsolete, use `>=' or `>>' instead
dpkg: warning: parsing file '/var/lib/dpkg/status' near line 12465 package 'indicator-session':
 `Depends' field, reference to `libcairo2':
 version value starts with non-alphanumeric, suggest adding a space
dpkg: error: parsing file '/var/lib/dpkg/status' near line 12465 package 'indicator-session':
 `Depends' field, reference to `libcairo2': version contains ` '
E: Sub-process /usr/bin/dpkg returned an error code (2)

The details I get from the update manager are:

    The following packages have unmet dependencies:

indicator-session: Depends: libc6 (>= 2.3.6-6~) but 2.15-0ubuntu10.10 is installed
                   Depends: libcairo2 (>= } 1.2.4) but 1.10.2-6.1ubuntu3 is installed
                   Depends: libdbus-glib-1-2 (>= 0.78) but 0.98-1ubuntu1.1 is installed
                   Depends: libdbusmenu-glib4 (>= 0.4.2) but 0.6.2-0ubuntu0.1 is installed
                   Depends: libdbusmenu-gtk3-4 (>= 0.4.2) but 0.6.2-0ubuntu0.1 is installed
                   Depends: libgdk-pixbuf2.0-0 (>= 2.22.0) but 2.26.1-1 is installed
                   Depends: libglib2.0-0 (>= 2.26.0) but 2.32.3-0ubuntu1 is installed
                   Depends: libgtk-3-0 (>= 3.0.0) but 3.4.2-0ubuntu0.7 is installed
                   Depends: libgudev-1.0-0 (>= 147) but 1:175-0ubuntu9.3 is installed
                   Depends: libpango1.0-0 (>= 1.14.0) but 1.30.0-0ubuntu3.1 is installed

Any help will be appreciated, Thanks.

EDIT: This is what I get when I run apt-cache policy indicator-session:

    indicator-session:
  Installed: 0.3.96-0ubuntu1
  Candidate: 0.3.96-0ubuntu1
  Version table:
     0.3.96-0ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ precise/main i386 Packages
 *** 0.3.96-0ubuntu1 0
        100 /var/lib/dpkg/status

marked as duplicate by Eric Carvalho, Fabby, Mitch Feb 20 '15 at 12:54

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Please add the output of apt-cache policy indicator-session to your question. – Florian Diesch Feb 18 '15 at 13:36
-1

sudo apt-get clean it will clean the repository or you dpkg is installing another package in Ubuntu software center or in another terminal. or you break any package during installing. check that and run sudo apt-get update

  • ok I ran sudo apt-get update and then ran sudo apt-get -f install and got the same results – michigankid79 Feb 18 '15 at 13:59
  • have u try sudo apt-get clean? – Senthil Anand Feb 18 '15 at 14:20
  • @michigankid79 please try sudo apt-getautoremove, sudo apt-get autoclean and finally try sudo apt-get update and sudo apt-get -f install. and reply please – Senthil Anand Feb 18 '15 at 14:36

Not the answer you're looking for? Browse other questions tagged or ask your own question.