1

From Windows Vista onward, previously joined networks are stored in the

HKLM\SOFTWARE\Microsoft\WindowsNT\CurrentVersion\NetworkList\Signatures\Unmanaged

registry key.

I am wondering if there is a file in Ubuntu that would contain similar information. At least the BSSIDs, and hopefully ESSIDs as well.

Any thoughts?

3

If you are network-manager (default) then you will find all the connections in /etc/NetworkManager/system-connections/ directory.

Open the file based on the connection name you want to check and you will find all the relevant information in the file.

2

Using the nmcli utility, you can get information about Network-Manager's previously-established network connections e.g.

nmcli con list

To limit the output to specific fields of interest, you can do something like

nmcli -f NAME,TIMESTAMP-REAL con list

which lists the connection name and time of last connection. You can also do more specific queries by connection ID or UUID e.g.

nmcli -f 802-11-wireless con list id "NETGEAR68-5G"

(quotes not mandatory unless the name contains spaces or other special characters), where in this case NETGEAR68-5G is the name of one of the previously-established connections as returned by the basic nmcli con list command. In this case, the 802-11-wireless field should include SSID, and BSSID if available.

  • Great information to have, however I receive a syntax error when using the nmcli -f 802-11-wireless con list command, and another when running it with ... id <ESSID>. At this point I don't see any values for BSSID anywhere.. – cremefraiche Feb 17 '15 at 23:57
  • Does the connection name include spaces? if so you will need to escape them or enclose it in quotes. Aside from that, it's hard to guess what the syntax error might be unless you post the full command. – steeldriver Feb 18 '15 at 0:00
  • $ nmcli -f 802-11-wireless con list yields Error: 'con list': invalid field '802-11-wireless'; allowed fields: NAME,UUID,TYPE,TIMESTAMP,TIMESTAMP-REAL,AUTOCONNECT,READONLY,DBUS-PATH and $ nmcli -f 802-11-wireless con list id <essid> yields Unknown parameter: Network23\nError: no valid parameter specified.. I am aware of escaping special characters, and is not needed at the moment. – cremefraiche Feb 18 '15 at 0:04
  • The 802-11-wireless field is only valid when specifying a connection by ID or UUID. I don't know why you are getting the second error (unless, as previously mentioned, the actual <essid> contains whitespace). – steeldriver Feb 18 '15 at 0:06
  • Interesting, I ran the same command with the same essid on my kali box and it worked. For some reason I an unable to run the last command on any networks displayed in my con list in 14.04. – cremefraiche Feb 18 '15 at 0:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.