7

Under Ubuntu 14.04, the trackpoint buttons (now again physical as opposed to X240) do not work properly. Left Button scrolls up, right button scrolls down, middle button does nothing.

How to resolve this issue?

  • I found this related issue with the Lenovo X1 (3rd gen): bugs.freedesktop.org/show_bug.cgi?id=88609 However, I could not replicate the solution suggested there (creating the file psmouse.conf with the proposed content shows no effect). Does anyone know how I can get the mapping for the trackpoint buttons right? – paul Feb 18 '15 at 20:52
  • I managed to get a partial solution to work. Purging synaptics and creating psmouse.conf enables the left trackpoint button but neither the middle button nor the right click work. Also, no drag and drop and scrolling are possible. Please help – paul Feb 22 '15 at 20:29
4

The problem is that Xorg will use the synaptics driver, which is not yet capable of handling the new hardware correctly. This can be circumvented by using evdev, and forcing the psmouse module, which takes care of the device at kernel-level, to recognize the device as legacy ImPS mouse.

No need to update your kernel, this works:

  1. Add the file /etc/modprobe.d/psmouse.conf with the following contents:

    options psmouse proto=imps

  2. Add the file /usr/share/X11/xorg.conf.d/90-evdev.conf:

    Section "InputClass"
        Identifier "Touchpad/TrackPoint"
        MatchProduct "PS/2 Synaptics TouchPad"
        MatchDriver "evdev"
        Option "EmulateWheel" "1"
        Option "EmulateWheelButton" "2"
        Option "Emulate3Buttons" "0"
        Option "XAxisMapping" "6 7"
        Option "YAxisMapping" "4 5"
    EndSection
    
  3. (May be optional; it is in Mint, it is not in Kubuntu) Update your initramfs to actually enforce loading the psmouse module correctly:

    sudo update-initramfs -u
    

Note: This solution works without updating your kernel. I have verified this with Linux Mint 17.1 64bit (kernel 3.13), Ubuntu 14.10 and Kubuntu 14.10 (both kernel 3.16). However, I also completely disabled the touchpad in the Lenovo BIOS. Disabling it there has no consequences without the instructions above, but is enforced when evdev is used as X driver, rather than synaptics.

Step (3) is not covered by the original blogpost at vimtips. Also, the code listing there has a typo (YAcisMapping).

Edit: Touchpad and Trackpoint, both are working out of the box (with synaptics) as of Ubuntu 15.04 (including all flavors).

  • Without updating the kernel this does nothing for me... (Ubuntu 14.04) – paul Feb 27 '15 at 22:36
  • 1
    Thank you! This worked for me. Unfortunately it has disabled some trackpad features like two-fingered scrolling. Any suggestions for how to fix it? – Thomas Apr 4 '15 at 17:53
2

This solution works:

http://vimtips.org/2015/02/20/ubuntu-1410-and-lenovo-thinkpad-x250/

1.) update kernel 3.18.7 2.) create file psmouse.conf then edit trackpoint buttons

  • The info on that link also works for me on t450s on 14.04.2, however I did not have to update the kernel. His info has been updated as well - I only had to do the grub boot parameters and add the xorg conf file. Everything works except full-pad-press-click and 2-finger swiping. – user184190 Mar 26 '15 at 22:35
0

The problem is gone with Ubuntu 15.04. So, if you just bought your X250, you may wish to upgrade to this version.

0

The problem is that Xorg will use the synaptics driver, which is not yet >capable of handling the new hardware correctly. This can be circumvented >by using evdev, and forcing the psmouse module, which takes care of the >device at kernel-level, to recognize the device as legacy ImPS mouse.

No need to update your kernel, this works:

Add the file /etc/modprobe.d/psmouse.conf with the following contents:

options psmouse proto=imps

Add the file /usr/share/X11/xorg.conf.d/90-evdev.conf:

Section "InputClass" Identifier "Touchpad/TrackPoint" MatchProduct "PS/2 Synaptics TouchPad" MatchDriver "evdev" Option "EmulateWheel" "1" Option "EmulateWheelButton" "2" Option "Emulate3Buttons" "0" Option "XAxisMapping" "6 7" Option "YAxisMapping" "4 5" EndSection

(May be optional; it is in Mint, it is not in Kubuntu) Update your >initramfs to actually enforce loading the psmouse module correctly:

sudo update-initramfs -u

This can be undone.

I lost two-finger scrolling on my trackpad when I did this. I removed 90-evdev.conf and psmouse.conf and rebooted and it did not revert to the old behavior. After removing the files (the above mentioned files you created when doing this) just run again this command:

sudo update-initramfs -u

and this should bring you back to the way it was before. I would leave a comment, but I guess I need 50 somethings to do that. Sorry admins and mods! Delete if you must...

Linux Mint 14.2 on Lenovo ThinkPad T440p

edited: confirmed my question and updated the question to a response.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.