6

Properties of the file

I have this video file with the extension .mkv but it is not playing in totem video player and this works in the new versions of VLC(Windows) and I havent tried it on VLC for Ubuntu yet. Is there any way to make this file run on the default totem player?

  • Why don't you just install vlc for Ubuntu? That should work - especially if you already know if works on VLC under windows. sudo apt-get install vlc – mkasberg Feb 17 '15 at 16:01
12

I had the exact same problem. This answer here solved the problem.

I followed the last one , i.e,

Install vlc with sudo apt-get install vlc and then install the required plugins to play *.mkv files by sudo apt-get install vlc-plugin-libde265

Note that, if the plugin installation gave you an error of not found, you will need to add it to the repo first

sudo apt-add-repository ppa:strukturag/libde265
sudo apt-get update

Now try opening the file in vlc.

  • Was driving myself crazy with various attempts until I found this solution. "sudo apt-get install vlc-plugin-libde265" works great, after first adding the repository! THANK YOU for posting this solution! – T. Greg O'Neil May 24 '16 at 19:54
  • 2
    Ubuntu 14.04 > Ubuntu software center > Search for VLC > Install directly worked for me. Without additional codecs. Holy ubuntu and holy stackoverflow =) – voghDev Sep 10 '16 at 17:10
  • exactly @voghDev – Rafaf Tahsin Sep 22 '16 at 18:21
  • 1
    @voghDev - Can you make that an Answer? I tried the sudo apt-get install vlc, only to be met with "no apt package 'vlc', but there is a snap with that name." But thanks to your comment, I got it :D – BruceWayne May 7 '19 at 3:00
  • 1
    @voghDev yeah, sorry if my comment wasn't clear. I found it via the GUI following the steps you gave. :) – BruceWayne May 7 '19 at 7:03
1

I tried implementing solution given by @severus, but still I got the error. I solved the probelm by installing an additional package using this command.

sudo apt-get install gstreamer0.10-libde265

1

I found it using the Ubuntu Software Center GUI instead of calling apt via console.

Ubuntu 14.04 > Ubuntu software center > Search for "VLC" > Install

This is whaty worked for me. No additional codecs needed.

Hope it works for you too!

0

Please go online (you must have internet connection running) when you try to run that file it will ask to search required codec then say yes it will install required codec, that's it.

Otherwise try this one:

sudo apt-get install ubuntu-restricted-extras
  • I had an active internet connection when I tried to run the file and it said Required plugin could not be found, and I've installed 'ubuntu-restricted-extras' and other video codecs play without any problem – Karthikeyan R Feb 18 '15 at 6:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.