1

So I had my partition tables gone corrupt somehow after writing a media file over the network to the external HDD of my media center. Following the steps from this answer, I tried quick- and deepscanning the disk with testdisk, but it couldn't find the (only) partition that was on the disk. This is what it says in the log file

search_part()
Disk /dev/sdb - 2000 GB / 1863 GiB - CHS 30400 255 63
BAD_RS LBA=244820282 11338172
check_part_i386 failed for partition type 06
     FAT16 >32M           15239  91 15 21480  61 20  100259781
BAD_RS LBA=846105701 16288174
check_FAT: can't read FAT boot sector
check_part_i386 failed for partition type 0E
     FAT16 LBA            52667 164 15 274072 233  6 3556875664
This partition ends after the disk limits. (start=846105701, size=3556875664, end=4402981364, disk end=488378645)
Search for partition aborted
Disk /dev/sdb - 2000 GB / 1863 GiB - CHS 30400 255 63
Check the harddisk size: HD jumpers settings, BIOS detection...
The harddisk (2000 GB / 1863 GiB) seems too small! (< 18 TB / 16 TiB)
The following partition can't be recovered:
     FAT16 LBA            52667 164 15 274072 233  6 3556875664

Results
   L FAT16 >32M           15239  91 15 21480  61 20  100259781
add_ext_part_i386: max
add_ext_part_i386: min

It keeps saying it finds these FAT16 partitions, which shouldn't be correct as the 2TB disk was a NTFS disk with a single partition. So is this going wrong because it wants to look for boot sectors or something? Which obviously aren't available since it was a mere data disk? And can I still recover my data using testdisk? Maybe with different options or something?

I also tried running photorec, but it seems to completely copy the contents of the disk to the location I specify, therefore I had to stop the scan, as I don't have a second 2TB disk just laying around for a scan...

Will I still be able to recover my partition or my data? Would photorec be the way to go if I can find a large enough drive?

1

I had a similiar issue 4 days back with my External Hard Disk which was in NTFS format.

Had mistakenly installed CENTOS in my External Hard Disk and entire data was deleted. I thought i would never get the data back. But someone in this forum suggested me to use TestDisk.

Used TestDisk, spent 5hours analysing and received same error message which you have posted.

I suggest PHOTOREC, which is installed along with TestDisk. It will easily recover data based on file types.

It may take more than 6hours but its worth your time.

Just type photorec in terminal and choose the file types like JPEG, PDF, MP4 or else it will scan for unknown extensions and it will take entire day.

| improve this answer | |
  • Thanks, I ended up running photorec myself, but I didn't know you could specify the extensions. But, how did you rename all the files? My data was full of movie and subtitle files and they are all named f00000 now, which is quite impractical. Did you find a way to automatically rename the files, or am I stuck renaming them manually :(? – Peter Raeves Feb 17 '15 at 18:56
  • 1
    Yes the files were renamed in f0000 patteren. There is no way you can automatically rename Movie files because they all have different name. I had manually renamed movie files by looking at the thumbnails, that was easy. But, it didn't help MP3 files. If you want to auto rename files in ubuntu then try this app. krename – Red Aura Feb 18 '15 at 4:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.