0

I purchased a VPS from namecheap and now I am trying to ssh in to it (Ultimate goal is to set up Ghost Blogging Platform on it).

I tried the following command -

$ ssh root@_ip_address_to_my_vps_

I get the following error -

The authenticity of host '_ip_address_to_my_vps_ (_ip_address_to_my_vps_)'
can't be established.
ECDSA key fingerprint is _fingerprint_redacted_.
Are you sure you want to continue connecting (yes/no)? y
Host key verification failed.

Yes, I know that there are tons of "host key verification failed" threads out there. But none of the solutions work. They all ask to generate the ssk key which I did as follows -

$ ssh-keygen -R _ip_address_to_my_vps_

The output indicates that the know_hosts file was updated but I continue to get the same error.

Any idea what I still haven't done?

0

On debian (and as far as I remember on 14.04 too) we have to type the full word "yes" instead of just "y" to answer the question "Are you sure you want to continue connecting (yes/no)?".

Otherwise there is a prompt telling "Please type 'yes' or 'no':"

Typing a full "yes" may be your solution (although the lack of error message is strange).

  • No. Does not work. – callmekatootie Feb 17 '15 at 15:08
  • By the way, "ssh-keygen -R " does not generate a new key, it does delete any previously recorded public keys for this server (at least for this IP), cf man ssh-keygen. – Quentin Feb 17 '15 at 17:21
  • You should not use this command everytime in your case, your problem is the exact opposite (you do not have a recorded public key, hence the error "The authenticity ... can't be established." – Quentin Feb 17 '15 at 17:26
  • Anyway, the behaviour of your ssh client is strange. What is the version installed on your computer ? (apt-cache policy openssh-client) – Quentin Feb 17 '15 at 17:29
0

I normally use something like

ssh-keygen -t rsa

without the ip address of the vps like you did and it works for me. From the ssh-keygen manpage:

-R hostname Removes all keys belonging to hostname from a known_hosts file. This option is useful to delete hashed hosts (see the -H option above).

Which I don't think is what you want

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.