2

I'm currently using mhddfs to mount three hard drives into a singluar pool directory. However, due to the allow_other option set, all users have full rw permissions in the pool directory (ignoring any set permissions on the files/folders). I know this is expected behaviour as the pool gets mounted as root and any user that changes into the pool's directory gets their permissions elevated to root.

Mount point in /etc/fstab:

mhddfs#/mnt/disk1,/mnt/disk2,/mnt/disk3 /storage/pool fuse defaults,allow_other,nonempty 0 0

It seems that allow_other doesn't care which user actually mounted the pool (same thing happens when I manually mount as myself). Naturally, taking that option out correctly limits the pool to my view only (ignoring any groups I'm in) but I want it viewable at the very least to other users in the same group set by the pool's permissions:

$ cd /storage && ls -l
drwxr-x--- 2 josh share 4096 Feb 16 17:57 pool

Any users in the share group should have read/execute perms. I'm currently exposing this pool via NFS, with all_squash set and anongid=1004 (id of share).

Is there a way to use mhddfs so that each user's permissions are properly respected when looking in the mounted pool, while still visible to all users? Somewhat similar to the way NFS's all_squash works. Having scoured manuals and other forums, I've turned up bupkiss.

1

I have noticed the same problem a few hours ago. Found some help in a FUSE manual.

The option "default_permissions" seems to do the trick. I've set it in fstab and after a small test it seems to respect the underlying permissions.

http://man7.org/linux/man-pages/man8/mount.fuse.8.html

| improve this answer | |
  • 1
    Seven months I have waited for this answer! Thank you so much! I have just remounted my mhddfs entry with this option set and I can confirm it is now adhering to the file permissions set. – Josh Stark Oct 12 '15 at 20:43
  • I've been doing some additional testing and it still seems to behave odd. Say i have normal mounts at /mnt/mnt1 and /mnt/mnt2. And a mhddfs mount for both at /mnt/mnt3. I set owner, group and other for mnt1 and mnt2 to have "none" permissions. Then i set /mnt/mnt3 owner, group and other to "read/write". It seems the permissions of mnt1 and mnt2 als get the "read/write" even though it doesn't show in the permissions info. Giving me a headache because i really like mhddfs. – Bofferman Oct 14 '15 at 12:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.