0

I have just installed Ubuntu 14.04 on my Lenovo y510p (I am dual booting windows 8.1 and Ubuntu). I am having trouble getting good wifi speeds when I use Ubuntu. Besides, the connection is unstable and would be dropped once in a while, prompting me to re-enter the wifi password. I don't have these issues when I am on Windows 8.1.

Any help would be greatly appreciated.

*-network
       description: Wireless interface
       product: Wireless 7260
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:09:00.0
       logical name: wlan0
       version: 73
       serial: fc:f8:ae:d2:12:b1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlwifi driverversion=3.13.0-45-generic firmware=22.24.8.0 ip=x.x.x.x latency=0 link=yes multicast=yes wireless=IEEE 802.11bgn
       resources: irq:48 memory:d5000000-d5001fff

*

http://paste.ubuntu.com/10286729/

0

Sounds like a classic issue with Intel wifi since Ubuntu 12.04 and it seems that the common solution is echo "options iwlwifi 11n_disable=8" | sudo tee -a /etc/modprobe.d/iwlwifi.conf and reboot

  • Thanks. I tried your suggestion, but it didn't work. I found this link and tried their fixes as well. (askubuntu.com/questions/119578/…) Now, my wifi is not as bad all the time. However, I still keep having these issues from time to time. Generally, a reboot fixes the issue. – Krishnendu Shekhar Feb 20 '15 at 1:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.