4

A few day ago I have installed libpcap0.8-dev but after that I installed libpcap0.8_1.4.0-2_amd64.deb and now I have tried almost of way to remove it but I can't! Since that, I can't install any package!!!

here is code:

$ sudo apt-get -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
  libpcap0.8
The following packages will be upgraded:
  libpcap0.8
1 upgraded, 0 newly installed, 0 to remove and 11 not upgraded
2 not fully installed or removed.
Need to get 0 B/110 kB of archives.
After this operation, 13,3 kB of additional disk space will be used.
Do you want to continue? [Y/n] Y
(Reading database ... 204351 files and directories currently installed.)
Preparing to unpack .../libpcap0.8_1.5.3-2_amd64.deb ...
Unpacking libpcap0.8:amd64 (1.5.3-2) over (1.4.0-2) ...
dpkg: error processing archive /var/cache/apt/archives/libpcap0.8_1.5.3-2_amd64.deb (--unpack):
 trying to overwrite shared '/usr/share/man/man7/pcap-filter.7.gz', which is different from other instances of package libpcap0.8:amd64
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Processing triggers for man-db (2.6.7.1-1ubuntu1) ...
Errors were encountered while processing:
 /var/cache/apt/archives/libpcap0.8_1.5.3-2_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

If I do:

$ sudo apt-get purge libpcap0.8-dev:i386 libpcap0.8:i386
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Package 'libpcap0.8-dev:i386' is not installed, so not removed. Did you mean 'libpcap0.8-dev'?
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 libpcap0.8-dev : Depends: libpcap0.8 (= 1.5.3-2) but 1.4.0-2 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

And if I just type sudo apt-get purge libpcap0.8-dev

$ sudo apt-get purge libpcap0.8-dev
[sudo] password for mark: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 libpcap-dev : Depends: libpcap0.8-dev but it is not going to be installed
 libpcap0.8 : Breaks: libpcap0.8:i386 (!= 1.4.0-2) but 1.5.3-2 is to be installed
 libpcap0.8:i386 : Breaks: libpcap0.8 (!= 1.5.3-2) but 1.4.0-2 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
3
  • What happens with just sudo apt-get purge libpcap0.8-dev?
    – Wilf
    Feb 16 '15 at 18:37
  • Thanks for answer @Wilf, i have answered your question above! thanks for help! Feb 16 '15 at 19:30
  • Take a look here and here Feb 22 '15 at 3:57
2

Thanks @Serg for answer my questions! Well,, I have resolved this, and this is easy to resolved. I post here for anyone has the same propblem! Here:

$ sudo apt-get purge libpcap0.8-dev libpcap0.8:i386 libpcap-dev
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages will be REMOVED:
  libpcap-dev* libpcap0.8:i386* libpcap0.8-dev*
0 upgraded, 0 newly installed, 3 to remove and 75 not upgraded.
2 not fully installed or removed.
After this operation, 1.034 kB disk space will be freed.
Do you want to continue? [Y/n] Y
(Reading database ... 204350 files and directories currently installed.)
Removing libpcap0.8:i386 (1.5.3-2) ...
Purging configuration files for libpcap0.8:i386 (1.5.3-2) ...
Removing libpcap-dev (1.5.3-2) ...
Removing libpcap0.8-dev (1.5.3-2) ...
Processing triggers for libc-bin (2.19-0ubuntu6.5) ...
Processing triggers for man-db (2.6.7.1-1ubuntu1) ...
Setting up libpcap0.8:amd64 (1.4.0-2) ...
Processing triggers for libc-bin (2.19-0ubuntu6.5) ...

It's so simple. Just sudo apt-get purge libpcap0.8-dev libpcap0.8:i386 libpcap-dev.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.