1

I have installed 14.04 LTS. I am having problems with the software updater and the system settings. The original install seemed to stop at a certain point. Right now, I am getting a partial upgrade for the software updater and it says DKMS: install completed. I then try to shut it down and I get the message that the upgrade is still running. This type of thing has happened several time before on the same install. My main question is: How doe you tell if the update or install is actually happening or if it is hung up? I have tried leaving these upgrades and installs go for up to 30 minutes with no results.

1

You are not alone. I had the same problem 2 weeks ago, I think its the ISO-file we used. I solved the problem by doing the first update via the terminal, hereafter the software updater worked just fine - every time.

Start terminal, and type or copy / paste the following: ( when asked for password type (blindly) your password)

sudo apt-get clean
sudo apt-get update
sudo apt-get upgrade
  1. removes the packages from your local repository
  2. fetches the new and updated packages
  3. do the actual installation

As an added bonus you can plainly see whats going on under the hood.

  • sudo apt-get update actually fetches the list of packages, not actual packages. – heemayl Feb 16 '15 at 19:32
  • Yes you are quite right, then there must be typos in the list, or newer names have slightly different spelling, why it will not update the gui-way first time is the mystery? – Ken Mollerup Feb 16 '15 at 19:42
  • tried all three approaches. This is what I get: Could not get lock /var/cache/apt/archives/lock - open (11: Resource temporarily unavailable) – Bill Delaney Feb 16 '15 at 20:36
  • Also, it occurs to me that I did not use an iso file. I already had 12.04 LTS. The upgrade was offered through 12.04 LTS in a pop up. I wander if that is the problem. I did try your solutions and they gave me this message: Could not get lock /var/cache/apt/archives/lock - open(11: Resource temporarily unavailable)- Have any other ideas? – Bill Delaney Feb 17 '15 at 3:14
  • On my system /var/cache/apt/archives/lock is an empty file of 0 bytes owned by root. It seems that file is missing or dammaged for some reason. Try rebooting and redo the 3 commands. – Ken Mollerup Feb 17 '15 at 8:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.