I have bought an MS-industral Fusion keyboard.The keyboard supports backlighting and I have tested it on my friends Windows 7 and it worked.I am using Ubuntu 14.10 and backlighting does not work.All the multimedia keys do work.

Backlighting control is actually on the same key as scroll lock and that also does not seem to work.

The only reason I bought this keyboard is because of backlighting.It is helpful for late night programming,gaming and text writing sessions.

Edit: I tested it on Openmandriva and Kali Linux right now and it does not work. I also tested it on the alpha/beta Ubuntu desktop next with unity8(15.04) and it worked.When I pressed the button it also activated scroll lock.So maybe if we fix scroll lock.

Edit2:It also works during boot time all the way until the login screen appears. Ediit3:It also works during shutdown.However I noticed if I use it during boot or shutdown it can hang the whole system.


Open Terminal then type:

xset led

enter, and see the magical happen!

  • 1
    for turn off keyboard backlight, just type "xset led off" on terminal ubuntu Mar 9 '17 at 2:07
  • thx great ! (worth an alias in bashrc)
    – mikakun
    Mar 20 '17 at 9:15
  • 2
    actually xset led is disabling numpad on my keyboard -> xset led 3 it is in my case at least
    – mikakun
    Mar 20 '17 at 9:33
  • @mikakun: oh, thanks, I just figure it out, xset led 3 turn on my keyboard backlight and my numpad working perfectly, thanks Mar 21 '17 at 7:32
  • 1
    "xset led" turned my numpad into a joystick!!
    – m4l490n
    Jul 31 '17 at 20:26

Run this command in termial (ctrl+alt+t):

xmodmap -e 'add mod3 = Scroll_Lock'

However, you have to do that each time you open a session.

Therefore, I suggest you define this command as a startup application, so that it's run automatically upon login :)

  • THE BEST! Works as a switch! + does NOT turn off the num lock! - perfect solution :) !
    – jave.web
    May 18 '20 at 13:22
  • Strange thing - even though all the keys seem to work in a "regular" places, like browser, file explorer, etc., they are not working in a video player x) guess that's a minor issue though
    – jave.web
    May 21 '20 at 7:57

I found my answer here in this link: https://answers.launchpad.net/ubuntu/+question/262205

  • that's a link not an answer
    – mikakun
    Sep 19 '18 at 8:23
  • 1
    Please do not post answers depending on external links. Put the relevant part into your answer (or post the link as a comment to the question if you have enough reputation). See How to Answer for details.
    – Melebius
    Oct 22 '18 at 14:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.