1

I'm trying out 14.04 using a USB drive. The first time I did this everything came up in German (which I was able to negotiate with some difficulty). The second time everything came up in Spanish, which I hardly know at all. I tried setlocale, but I get no se encontró la orden, which I guess means "command not found." (For some reason sudo setlocale returns the same message -- but in English!) Here is what's in /etc/default/locale:

LANG="es_ES.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"

So how do I change that first line -- can I just edit the file /etc/default/locale?

  • Are you not prompted to chose your language after boot in the menu with the options "Try Ubuntu" and "Install Ubuntu"? There should be a long list on the left afaik... – Byte Commander Feb 16 '15 at 16:36
  • No, @ByteCommander, I just get a blank screen. When I move the cursor to the icons on the left their names appear (currently) in Spanish: "Instalar Ubunti 14.04.1 LTS," "Archivos," etc. – JEG Feb 16 '15 at 17:07
  • huh? Strange! Screenshot? Did you validate the hash number of the Ubuntu image you downloaded and where did you get it from? – Byte Commander Feb 16 '15 at 17:09
  • No, I didn't validate anything. I got it from Releases.Ubuntu.com. Rather than starting all over again, I'd much prefer just fixing this problem so I can do a proper installation (and understand what the process tells me...). – JEG Feb 16 '15 at 17:23
  • You have a live system at the moment, right? So the only thing you would have to do is to manually compare the hashes of the iso-file you downloaded with the one you can read at the Ubuntu download page. If your installation image has errors, you will only make it worse and get more errors and unexpected behavior the more you use it! – Byte Commander Feb 16 '15 at 17:26
1

All that was necessary to fix the language problem: editing /etc/default/locale and correcting the first line to read

 LANG="en_US.UTF-8"

like the other lines. After a reboot everything was fine.

As muru stated: I didn't need to generate new locales as en_US.UTF-8 was already used on my system

  • And running locale-gen or sudo dpkg-reconfigure locales as needed. – muru Feb 16 '15 at 20:39
  • No, I hadn't done that, but I'm always ready to take advice, so I ran locale-gen just now. (I'm not sure what it does, except give me a long list of languages...) – JEG Feb 16 '15 at 21:02
  • if you're adding a new locale, then you'll need it. Since you were already using the locale for some settings, probably nothing needed to be generated. – muru Feb 16 '15 at 21:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.