When I run fsck -fy in a terminal it says something similar to:

WARNING!! FILE SYSTEM MOUNTED!! You will cause seviere damages.

Why is that? This might be a little off-topic but I ran that command under Mac OS X and it didn't complain about anything, nothing bad happened.

I have the familiar setup, Mac G4 800mhz 832mb ram lubuntu 11.04

  • It might be easier to help you if you tell us about your setup. – N.N. Aug 25 '11 at 12:16

Running fsck -fy on a mounted ext3/ext4 formatted drive is not recommended because logically, it will be trying to analyse for inconsistencies on effectively a moving target. The action of modifying the filesystem means that anything you have analysed will have to be reanalysed.

There is very similar question and answer on the Unix Stackoverflow site that has more detail as to why it is a bad idea.


Mac OS X uses a different file system type (HFS+), which based on your feedback (I don't use it) can be checked with the filesystem mounted. Ext3 and Ext4 can not be safely checked while mounted.


You cannot do that because you can cause damage to the partitions.

What you can do is first umount the disk you're interested in and do the fsck, if it's the root disk, the simplest thing you can do is to run an ubuntu live cd and run it from there.

  • you're using the ``f'' option that means fix, so in some cases it could modify the partition if it finds errors. – Ignacio Bermudez Aug 26 '11 at 6:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.