1

I set up a new system and took the .thunderbird folder from my old home directory and placed it in my new home directory. With most things the applications open back up exactly as I had them on my last system and I expected the same with Thunderbird.

When I open it, it's like a brand new installation and it asks if I'd like to create an email address.

  • I ran 'thunderbird -p' and made sure the correct (and only) profile was selected, but still nothing.
  • I tried removing the .thunderbird directory altogether, opening Thunderbird to generate it, and then replacing the contents with my old profile and still nothing.
  • I checked the permissions on the files and they are correct, and I can go through the folders and see calendar/email/contact data, so I'm not sure what the problem is.

Any ideas?

  • In case the last version of the profile was corrupt I restored the .thunderbird folder from one day before and it worked. I diffed through to see what the difference was and the only file that was different besides actual calendar/email data was the existence of a .parentlock file in the WORKING backup. I would think if anything the existence of a lock file would make it less like to work. I have not tried going back to the non-working profile and adding this .parentlock file to see if it would fix it though. – jchysk Feb 16 '15 at 3:57
0

I have found that if I keep trying to start Thunderbird, it may or may not eventually start.

What is more telling is that I have the TB profile and all data files on a separate partition, which the TB launcher seems not to like. If I open that partition in Nautilus, for example, then start Thunderbird, it will pick up the profile and will start ok.

Design flaw, as I can see it, because Thunderbird should be able to access that partition straight off.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.