1

I have included at the end some rc.lua code copied nearly verbatim from vicious README examples. (The set_color line needed an additional "}" and I changed BAT0 to BAT1).

awmtt.sh gives me an error:

/usr/share/awesome/lib/awful/widget/progressbar.lua:188: attempt to index field '?' (a nil value)

If I go to the file in question, it is trying to access data[progressbar].height, suggesting data has no member progressbar.

Ubuntu 14.04, awesomeWM 3.4. Thanks in advance for any help.

batwidget=awful.widget.progressbar()
batwidget.set_height(10)
batwidget.set_width(8)
batwidget.set_vertical(true)
batwidget:set_background_color("#494B4F")
batwidget:set_border_color(nil)
batwidget:set_color({ type = "linear", from = { 0, 0 }, to = { 0, 10 },
     stops = { { 0, "#AECF96" }, { 0.5, "#88A175" }, { 1, "#FF5656" }}})
vicious.register(batwidget, vicious.widgets.bat, "$2", 61, "BAT1")
1

I cannot check it myself at the moment, but if you look here in the awesome wiki you can see that you use the syntax for awesome 3.5 instead of 3.4 at the batwidget:setcolor line.

Also,

batwidget.set_height(10)
batwidget.set_width(8)
batwidget.set_vertical(true)`

should be

batwidget:set_height(10)
batwidget:set_width(8)
batwidget:set_vertical(true)
| improve this answer | |
  • Thank you. Your two comments were spot on. Thanks for helping a newb along the learning curve. – user3391229 Mar 1 '15 at 4:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.