1

I recently installed Ubuntu onto my PC. When I went to install it, there was no option to install alongside Windows, so I partitioned space for it myself. Ubuntu booted up just fine, but when I went back to boot up Windows, it didn't show up in my Grub menu. I tried "sudo os-prober" but got nothing in return from the Terminal. I also tried updating Grub, but no cigar.

So my question is actually dual in purpose, because I want to learn about this kind of stuff: 1. How do I figure out what is still on all my disks, and
2. How do I recover Windows 7?

And I guess, finally, if worst comes to worst, I can do a clean reinstall of Windows from a buddy's system, correct?

Edit: "Disk /dev/sda: 750.2 GB, 750156374016 bytes
255 heads, 63 sectors/track, 91201 cylinders, total 1465149168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0x0006e059

Device Boot      Start       End                   Blocks           Id      System
/dev/sda1   *      2048     1465147391 732572672 83     Linux"

http://paste.ubuntu.com/10284506/

  • 1
    Start with sudo fdisk -l and let's see if the partition is still there, please add these into your original post – Geary Shull Feb 15 '15 at 16:30
  • Added, and also put in my boot repair paste. – Spartan Feb 18 '15 at 4:25
1

I think you made a mistake while partitioning the drive, so most probably the Windows 7 is formatted or else it should have showed up in output of fdisk -l command.

One final solution you can try is re-installing GRUB BOOT REPAIR. Type these commands in terminal.

sudo add-apt-repository ppa:yannubuntu/boot-repair
sudo apt-get update
sudo apt-get install -y boot-repair && boot-repair

This will fix the Grub boot loader and will display windows 7 if its still there.

| improve this answer | |
  • All right. I ran Boot Repair, and Windows 7 was not shown. I would assume that means I overwrote Windows when I manually partitioned Ubuntu, correct? I also attempted using TestDisk, but that program was also only able to find Linux partitions. I guess I'm dead in the water? lol – Spartan Feb 18 '15 at 20:32
  • Hey don't give up. Try Photorec which is installed with TestDisk. Just type photorec in terminal. It will show the partition and also has an option to recover files based on file types like mp3, jpeg, mp4. This will help you recover data faster. – Red Aura Feb 19 '15 at 3:05
  • Nailed it! Photorec worked, and I was able to recover the files. Thanks for the help. :D – Spartan Feb 19 '15 at 7:16

Not the answer you're looking for? Browse other questions tagged or ask your own question.