I have made a disk image file of /dev/sda1 partition which has windows xp recovery environment. The file is 20.1 GB stored on a ext4 partition, when I am going to open it with the tool of disks app to mount disk images, it says the following:Error opening /media/george/Storage/sda1.img : Value too large for defined data type.

(my language on ubuntu is greek, so I translated it from google translate). What does it means? Is the file too large to be mounted? Does it have any problem because it is made from a manufacturer partition designed for restoring windows xp?

  • Are you on a 32-bit system? (If you're not sure, see System Settings/Details). – Jos Feb 15 '15 at 11:25
  • 1
    Hint for your language problem to avoid bad google translations: You can run a single command in the default fallback language (usually English) by typing LANG=C before the actual command in terminal. Example: LANG=C sudo apt-get update You can also start GUI applications like gparted in English this way: LANG=C gparted-pkexec& (gparted-pkexec is the executable name, & frees the terminal - it would belong to gparted otherwise and exiting the terminal window would also kill the GUI application) – Byte Commander Feb 15 '15 at 12:33
  • +Byte Commander Even though you are free to use the terminal for other stuff if you use the &, exiting the terminal would still kill the process. If you use LANG=C nohup > /dev/null gparted-pkexec &, you can then safely close the terminal. – Hitechcomputergeek Oct 8 '15 at 17:27
  • +Hitechcomputergeek Actually, an even better way is to use LANG=C setsid gparted-pkexec. – Hitechcomputergeek Nov 11 '15 at 4:12

There's a relic called ulimit. For fun enter ulimit -a to see what's going on.

If you bump into any limits try ulimit -f unlimited and give it another go. More information about this forgotten and mostly unnecessary gem is found in the man page.

Edit: A bit more information is down this link https://stackoverflow.com/questions/14471564/what-does-ulimit-s-unlimited-do, but you want the file flag, which is -f.

Edit: and that would be sudo ulimit -f unlimited unless you are already root, but you probably knew that.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.