To my dismay, I have attempted to install several Linux systems in the past month. I have tried Oz Unity's Star Sapphire 3 times now without success. The first time it installed without issue, restarted after removing cd just fine,but after updating and trying to launch Steam and install Steam games. On reboot, it hung overnight and went to a black screen with lots of errors.

I restarted and chose the recovery option but nothing worked and fdsk did not fix it, it hung overnight at 2%. I decided to reinstall, installation hung and went to 's to skip or m for manual recovery', manual recovery just gave more error messaes and I did not feel confident to tackle this.

So I tried another install, this time I wiped the hard drive with Webroot System Eraser and it seemed to be going a thousand times quicker but hung at install after a couple of error messages about Glib while copying files: 'Source ID 3498 etc was not found when attempting to remove it'. I did select Erase all files and install at the splash screen as there was no other option for install (even though I had wiped the drive).

After reading a post about Steam games not working in Star Sapphire I decided to try Ubuntu 14.04.1 as several forums suggested Steam works in Ubuntu. It seemed to install fine but on reboot I get a black screen with copious process error messages. No Grub. System Rescue Cd provided no fixes.

The last attempted reinstall today with Ubuntu 14.04.1 in UEFI, the install process went all the way to restart, I tried to install updated while configuring hardware and that failed, at the prompt I removed the cd and press enter, then a black screen for ages, then appeared '[195.952592] systemd-udevd (348): timeout 'mtp-probe/sys/devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.3 1 4', a very, very long delay then, Purple Ubuntu loading screen for another very long time, then black, it then switched off. When I switched it back on a purple boarder appeared around the edge then black - nothing. I hard powered it off and back on, black screen, no grub.

I am at my wits end! I am desperate NOT to go back to Windows (it kept hanging after 20-30 mins after bootup) and want a Linux OS.

My system may have a lot to do with it but I also suspect the BIOS setting are not working. It is a 2013 (less than 2 years old) Medion Akoya with Windows 8 pre-installed (was as it has since been wiped). I have followed all the Ubuntu official guides for UEFI turning off 'Secure Boot' etc. I've tried changing boot type from UEFI to Dual to Legacy. I have promoted the boot sequence to CDROM.

Nothing is working and I feel like I have a $500 brick that used to be the center of our home entertainment.

Laptop: Medion Akoya E6232 (MD 99222) notebook Processor: Intel 3rd gen Core i3 2.5GHz Intel Core i3-3120M RAM: 4.00 GB Intergrated Graphics Card: Intel HD 4000 Internal storage: 500GB

1 Answer 1


Take a deep breath.

Generally problems like you're describing come from two areas

  1. A corrupted system image on the installation media. Check the checksum to avoid wailing and gnashing of teeth. A corrupted image only leads to tears.
  2. Hardware failure, or impending hardware failure.

If you have a bona fide image on a USB in the form of a LiveCD, and the LiveCD boots, and runs, use the tools on the LiveCD to verify the integrity of your hardware, and *pre-*setup your machine to accept the new system.

  • Use GParted and partition it as you wish. I have a personal preference to at least 3 partitions (swap partition equivalent to RAM size; /, a root partition 10-30GB, depending; and the rest of the space devoted to /home)


  • /dev/sda1 = / (root)
  • /dev/sda2 = /home
  • /dev/sdaX = swap

The order and numerical sequence is more important the OCD you are.

Now, after you have partitioned and formatted this unknown harddrive, check and mark any badblocks that might give you a bad day.

  • Open a terminal <ctrl><alt><t> at the same time, and enter sudo badblocks -v /dev/sda > bad-blocks

This goes over the drive and notes any 'bad blocks' and writes the information to a file bad-blocks in the current working directory (on the LiveCD).

  • While it's churning away this is a good time to check if the machine is overheating. Granted it's subjective, but does it feel hot? Are the vents clear and the feel/hear the fans blowing off the heat?

  • Remove any bad block from future use via the bad-blocks file you have just finished creating sudo fsck -t ext4 -l bad-blocks /dev/sda changing the ext4 to the format you laid down on the partitions.

  • Run some of the memory tests available when as you boot up the LiveCD. You don't have to run the whole series, but just let it run for 10 minutes to see if it throws an error. (If it does, then that's another matter.) What you are looking for is a point of failure; image and hardware integrity, a sloppy USB connector...something that might suggest not everything is optimal for a carefree installation.

Everything passes?...the machine doesn't overheat, or spit up running from the LiveCD after running through its paces, and a test drive on the internet, or whatever?

Now, try an installation, using the Something else option, and place the system in your pre-defined partitions.

Good luck.

  • Thanks so much, Nodak! I have hope now! Am giving it a go as I type. I have put the BIOS settings back to Dual boot (both UEFI and Legacy) as that was the last setting that was most successful (and the first try at installing). What type of file system should /root be in? In G-parted it says it's fat32. I read elsewhere it should be ext2 (grub) or ext4 (grub2). What is correct?? I have also installed Boot Repair just in case. I'm not sure if this will be of any assistance as Grub loads fine, it just hasn't progressed anywhere after that in previous installs. Feb 18, 2015 at 2:27
  • G-parted has crashed. When I tried to update gparted is said there was no space left on disk. Am running the USB Live CD as advised. Feb 18, 2015 at 3:15
  • Rather than update GParted, if GParted is crashing that would point more toward a corrupted image. I don't know what tool you have on hand, but I'd recommend heading down this path help.ubuntu.com/community/HowToMD5SUM
    – Nodak
    Feb 18, 2015 at 4:12
  • Partition format, to a degree, is a matter of preference and intended end use. On a home machine, 99.44% of the time you can't go wrong with ext4. help.ubuntu.com/community/LinuxFilesystemsExplained
    – Nodak
    Feb 18, 2015 at 4:17
  • I download a fresh Ubuntu 14.04.1 image and created a fresh LiveCD. On boot, when the screen goes purple, hit <Shift> and then <esc>. This gives you a boot menu. 3rd option down the list is the ability to check the integrity of the LiveCD. Give that a go. Obviously if it fails...start again. If it doesn't fail...well, that's another kettle of fish.
    – Nodak
    Feb 18, 2015 at 4:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .